战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。
输入格式:
输入在第一行给出两个整数N
(0 < N
≤ 500)和M
(≤ 5000),分别为城市个数(于是默认城市从0到N
-1编号)和连接两城市的通路条数。随后M
行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K
和随后的K
个被攻占的城市的编号。
注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。
输出格式:
对每个被攻占的城市,如果它会改变整个国家的连通性,则输出Red Alert: City k is lost!
,其中k
是该城市的编号;否则只输出City k is lost.
即可。如果该国失去了最后一个城市,则增加一行输出Game Over.
。
输入样例:
5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3
结尾无空行
输出样例:
City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.
解题步骤:先用并查集求一下初始连通分支数 C ,每攻占一个城市就重新求一次连通分支数 C1(注意跳过被攻占城市的边),每次将C1与C比较,输出相应的结果。C1 C有3种情况,
一、 C1=C 表明被攻占的城市在一个环里,被攻占了也不影响原图的连通性
二、 C1=C+1 表明被攻占的城市只连接了一个城市,即图的最外层
三、C1-C >1, 表明被攻占的城市至少连接两个城市,被攻占后连通分量至少增加2.
易错:1.注意城市被攻占并不是要真的删除它,而是不去统计它连接的边。
2.每次都是与攻占该城市前的前的连通分量比较,注意更新初始的连通分量。
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int N = 5010;
int n, m, k;
int flag[N];
struct edge
{
int a, b;
}edge[N];
int p[N];
void init()
{
for(int i = 0; i < n; i++) p[i] = i;
}
int find(int x)
{
if(p[x] != x) p[x] = find(p[x]);
return p[x];
}
int count()
{
int cnt = 0;
for(int i = 0; i < n; i++)
if(find(i) == i) cnt++;
return cnt;
}
int main()
{
cin >> n >> m;
init();
for(int i = 0; i < m; i++)
{
int x, y;
scanf("%d %d", &x, &y);
edge[i] = {x, y};
int px = find(x), py = find(y);
if(px != py) p[px] = py;
}
int cnt1 = 0, cnt2 = 0, cnt = 0;
cnt1 = count();
cin >> k;
while(k--){
int x;
cin >> x;
cnt ++, cnt2 = 0;
flag[x] = 1; // 被攻占了
init();
for(int i = 0; i < m; i++)
{
if(!flag[edge[i].a] && !flag[edge[i].b])
{
int px = find(edge[i].a), py = find(edge[i].b);
if(px != py) p[px] = py;
}
}
cnt2 = count();
if(cnt1 == cnt2 || cnt1 + 1 == cnt2) cout << "City " << x << " is lost." << endl;
else cout << "Red Alert: City " << x << " is lost!" << endl;
cnt1 = cnt2;
if(cnt == n)
{
cout << "Game Over.";
break;
}
}
return 0;
}