7-6 列出连通集 (25 分)
给定一个有N个顶点和E条边的无向图,请用DFS和BFS分别列出其所有的连通集。假设顶点从0到N−1编号。进行搜索时,假设我们总是从编号最小的顶点出发,按编号递增的顺序访问邻接点。
输入格式:
输入第1行给出2个整数N(0<N≤10)和E,分别是图的顶点数和边数。随后E行,每行给出一条边的两个端点。每行中的数字之间用1空格分隔。
输出格式:
按照"{ v1 v2 ... vk }"的格式,每行输出一个连通集。先输出DFS的结果,再输出BFS的结果。
输入样例:
8 6
0 7
0 1
2 0
4 1
2 4
3 5
输出样例:
{ 0 1 4 2 7 }
{ 3 5 }
{ 6 }
{ 0 1 2 7 4 }
{ 3 5 }
{ 6 }
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
const int N = 11;
int g[N][N];
int st[N];
int n, m;
void dfs(int u)
{
cout << u << ' ';
st[u] = true;
for(int i = 0; i < n; i++)
if(!st[i] && g[u][i]) dfs(i);
}
void bfs(int u)
{
queue<int> q;
q.push(u);
st[u] = true;
while(q.size())
{
auto t = q.front();
q.pop();
cout << t << ' ';
for(int i = 0; i < n; i++)
if(!st[i] && g[t][i]) {
q.push(i);
st[i] = true;
}
}
}
int main()
{
cin >> n >> m;
while(m--)
{
int a, b;
cin >> a >> b;
g[a][b] = g[b][a] = 1;
}
for(int i = 0; i < n; i++)
{
if(!st[i])
{
cout << "{ ";
dfs(i);
cout << "}" << endl;
}
}
memset(st, 0, sizeof st);
for(int i = 0; i < n; i++)
{
if(!st[i])
{
cout << "{ ";
bfs(i);
cout << "}" << endl;
}
}
return 0;
}