pat甲级1001

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

        这道题就是计算两个数字相加,因为两个数字的长度都不大于10^6次方,所以用int类型不会溢出。

        将计算结果转换成字符串更好处理,如果第一位是“-’则直接输出,将“-”删除掉。剩下的数据,只要每三位加一个“,”,拼接起来输出即可。

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a;
    int b;
    cin>>a>>b;
    string temp =to_string(a+b);
    if(temp[0]=='-'){
        cout<<'-';
        temp.erase(0,1);
    }
    int z =0;  
    for(int i=temp.length()-1;i>=0;i--){
        z++;
        if(z%3==0&&i>0){
            temp.insert(i,",");
        }
    }
    cout<<temp;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

狗头实习生

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值