AVL树 - 理解记忆与编程题模板(PAT 1066 Root of AVL Tree)

AVL树的编程题比较麻烦,如果不是对AVL很了解就很容易写错。即使写对也会浪费时间。下面针对AVL编程问题的一个典例来理解和掌握AVL树问题的基本操作。理解和记忆之后可以在考试中直接用。

问题:

1066 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpg

 

F2.jpg

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

结尾无空行

Sample Output 1:

70

结尾无空行

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

来源:

https://pintia.cn/problem-sets/994805342720868352/problems/994805404939173888

直接代码加图片加深理解,口诀记忆。以后遇到AVL就是无脑背代码。

#include <iostream>

using namespace std;

struct node

{

    int val;

    struct node *left, *right;

};

     ->      

node *rotateLeft(node *root)//右右插入需左旋

{

    node *t = root->right;

    root->right = t->left;

    t->left = root;

    return t;

}

     ->     

node *rotateRight(node *root) {//左左插入需右旋

    node *t = root->left;

    root->left = t->right;

    t->right = root;

    return t;

}

  ->  

node *rotateLeftRight(node *root) {//左右插入左右旋

    root->left = rotateLeft(root->left);//左子树左旋

    return rotateRight(root);      //根节点右旋

}

  ->  

node *rotateRightLeft(node *root) {//右左插入右左旋

    root->right = rotateRight(root->right);//右子树右旋

    return rotateLeft(root);         //根节点左旋

}

int getHeight(node *root) 

{

    if(root == NULL) return 0;

    return max(getHeight(root->left), getHeight(root->right)) + 1;

}

node *insert(node *root, int val) {

    if(root == NULL) {

        root = new node();

        root->val = val;

        root->left = root->right = NULL;

    } else if(val < root->val) {

        root->left = insert(root->left, val);

        if(getHeight(root->left) - getHeight(root->right) == 2)

            root = val < root->left->val ? rotateRight(root) : rotateLeftRight(root);

    } else {

        root->right = insert(root->right, val);

        if(getHeight(root->left) - getHeight(root->right) == -2)

            root = val > root->right->val ? rotateLeft(root) : rotateRightLeft(root);

    }

    return root;

}

int main() {

    int n, val;

    scanf("%d", &n);

    node *root = NULL;

    for(int i = 0; i < n; i++) {

        scanf("%d", &val);

        root = insert(root, val);

    }

    printf("%d", root->val);

    return 0;

}

程序来源:https://www.liuchuo.net/archives/2178

图片来源:我亲爱的弄夫哥哥https://www.bilibili.com/video/BV1Mt4y197kC?p=66

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值