7-3 汽车超速罚款

许多社区都有“雷达”标志,告诉司机他们的速度是多少,希望他们能够慢下来。
你将输出一个“雷达”标志的信息,根据司机驾驶车速的情况向他(她)显示信息。

在此,郑重地提醒各位小伙伴们:在道路上驾驶机动车一定要遵守交通规则,注意交通安全!道路千万条,安全第一条!!!

输入格式:

在一行内输入2个整数。第一个表示速度的限制,第二个表示司机的开车速度。

输出格式:

如果司机没有超速,输出应该是:Congratulations, you are within the speed limit!
如果司机超速行驶,输出为:You are speeding and your fine is F.(F为上表中描述的罚款数)

输入样例1:

40 39

输出样例1:

Congratulations, you are within the speed limit!

输入样例2:

100 131

输出样例2:

You are speeding and your fine is 500.

输入样例3:

100 120

输出样例3:

You are speeding and your fine is 100.

//代码

import java.util.Scanner;

public class Main { 
            
       public static void main(String[] args) { 

       Scanner input = new Scanner(System.in);

           int limitspeed=input.nextInt();

           int speed=input.nextInt();

           if(speed<=limitspeed)
               System.out.println("Congratulations, you are within the speed limit!");
           else if(speed-limitspeed<=20)
               System.out.println("You are speeding and your fine is 100.");
           else if(speed-limitspeed<=30)
               System.out.println("You are speeding and your fine is 270.");
           else
               System.out.println("You are speeding and your fine is 500.");
       }
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

计算机小白中的小白

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值