【P4343】【二分】[SHOI2015]自动刷题机

用二分寻找最大于最小值。

二分的核心通常是寻找查找的方向即check()函数

check()函数:返回A了几道题目,A多了说明行数n取小了,否则行数n取大了。

check()函数源码:

ll check(ll x)
{
	ll ans = 0, cnt = 0;
	for (int i = 1; i <= n; i++) {
		ans += a[i];
		if (ans >= x) {
			ans = 0;
			cnt++;
		}
		else if (ans < 0) {
			ans = 0;
		}
	}
	return cnt;
}

然后就可以快乐的二分了......

样例输入:

4 2
2
5
-3
9

样例输出:

3 7

代码:

#include<iostream>
#include<string>
using namespace std;
typedef long long ll;
const ll inf = 1e18 + 7;
const int N = 1e5 + 5;
ll n, k, a[N];

ll check(ll x)
{
	ll ans = 0, cnt = 0;
	for (int i = 1; i <= n; i++) {
		ans += a[i];
		if (ans >= x) {
			ans = 0;
			cnt++;
		}
		else if (ans < 0) {
			ans = 0;
		}
	}
	return cnt;
}

int main()
{
	cin >> n >> k;
	for (int i = 1; i <= n; i++) {
		cin >> a[i];
	}
	ll L = 1, R = inf, maxu = -1, minu = -1;
	while (L <= R)
	{
		ll mid = L + (R - L) / 2;
		ll ans = check(mid);
		if (k <= ans) { // 做的题太多,mid小了
			if (ans == k)
				maxu = mid;
			L = mid + 1;
		}
		else {
			R = mid - 1;
		}
	}

	L = 1, R = maxu;
	while (L <= R)
	{
		ll mid = L + (R - L) / 2;
		ll ans = check(mid);
		if (k >= ans) { // 做的题太少,mid大了
			if (ans == k)
				minu = mid;
			R = mid - 1;
		}
		else {
			L = mid + 1;
		}
	}

	if (maxu == -1) cout << -1 << endl;
	else {
		cout << minu << ' ' << maxu << endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Sophon、

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值