1019 General Palindromic Number (20 分)

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0in base b≥2, where it is written in standard notation with k+1digits ai​ as ∑i=0k​(ai​bi). Here, as usual, 0≤ai​<b for all i and ak​ is non-zero. Then N is palindromic if and only if ai​=ak−i​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​ ak−1​ ... a0​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

初始12分代码:


#include<iostream>
#include<sstream>
using namespace std;

string translate(int num,int base){
    string s="";
    int t=1;
    while(num/base!=0){
        if(t==1){
            s=to_string(num%base)+s;
            num=num/base;
            t--;
        }
        else{
            s=to_string(num%base)+" "+s;
            num=num/base;
            
        }
    }
    s=to_string(num%base)+" "+s;
    return s;
}

int main(){
    int N,b;
    int i;
    cin>>N>>b;
    string num=translate(N, b);
    if(num.size()==2){
        cout<<"Yes"<<endl<<num;
        exit(0);
    }
    for(i=0;i<num.size();i++){
        if(num[i]==num[num.size()-i-1]){
            continue;
        }else {
            cout<<"No"<<endl<<num;
            exit(0);
        }
        
    }
    cout<<"Yes"<<endl<<num;
}

是一个很简单的进制转换,回文判断题,但是有8分得分点没有得分,猜测关键的坑在于如果最后输出为“15 6 15”的话才算回文,而不是“15 6 51”,因此像上述那样利用字符串进行检测是会出错的,这里初步考虑建立一个大小确定的数组,正好可以容纳所有位上的数字,就可以利用该数组进行判断回文。

大小如何确定呢?

这里可以使用上面已经定义好的函数的思想再写一个函数,关键部分修改为计数就好;

int count(int num,int base){
    int t=1;
    while(num/base!=0){
        t++;
    }
    return t;
}

中间经历了一些波折

1.C++并未直接给出获取数组长度的函数,因此需要手动计算,计算公式为:

int array[10];

int size=size_of(array)/size_of(array[0]);

2.识别连续数字,并将其放入数组

这里的繁杂考虑主要在于字符串的处理以及数组首末端的处理

首端记得先处理,末端不要忘记处理

这里的是判断i是否为空格,以及是否到末尾,通过这个条件来进行对数组的输入操作

这里做的不好,应该利用i+1判断下一个是否为空格,

 int m=0;
    m=num[0]-'0';
    for(i=1;i<=num.size();i++){
        string s="";
        if(num[i]!=' '&&i!=num.size()){
            m=m*10;
            m=m+(num[i]-'0');
            
        }else {
            group[j]=m;
            j++;
            m=0;
        }
    }

修改过后的代码为


#include<iostream>
#include<sstream>
using namespace std;

string translate(int num,int base){
    string s="";
    int t=1;
    if(num<base){
        s=to_string(num);
    }
    else{while(num/base!=0){
        if(t==1){
            s=to_string(num%base)+s;
            num=num/base;
            t--;
        }
        else{
            s=to_string(num%base)+" "+s;
            num=num/base;
            
        }
    }
        s=to_string(num%base)+" "+s;
    }
    return s;
}


int countel(int num,int base){
    int t=1;
    while(num/base!=0){
        t++;
        num=num/base;
    }
    return t;
}

int main(){
    int N,b;
    int i,j=0;
    cin>>N>>b;
    
    string num=translate(N, b);
    int size=countel(N,b);
    int group[size] ;
    
    //将所有数字以int的形式存入group
    int m=0;
    m=num[0]-'0';
    for(i=1;i<=num.size();i++){
        string s="";
        if(num[i]!=' '&&i!=num.size()){
            m=m*10;
            m=m+(num[i]-'0');
            
        }else {
            group[j]=m;
            j++;
            m=0;
        }
    }
    //判断回文
    int mat=sizeof(group)/sizeof(group[0]);
    for(i=0;i<mat/2;i++){
        if(group[i]==group[mat-i-1]){
            continue;
        }
        else{
            cout<<"No"<<endl<<num;
            exit(0);
        }
    }
    cout<<"Yes"<<endl<<num;
}

运行结果:

总体来说非常简单,想拿十分不难,想拿满分的话需要考虑较多的东西

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
这段代码也可以实现在一个区间内寻找回文数并计算它们的和。 其中 `isPalindromic` 函数用于判断一个数是否为回文数,`getInputs` 函数用于获取区间的上边界和下边界,并检查用户的输入是否合法。在主程序中,我们首先调用 `getInputs` 函数获取区间的上边界和下边界,然后通过循环遍历这个区间,找到其中所有回文数,并将它们存储在一个列表中。最后,我们计算这些回文数的总和,并输出结果。 这段代码的工作流程与之前的示例代码基本相同,唯一的区别是在输入区间时,代码将上边界和下边界别存储在 `upper` 和 `lower` 变量中,并检查它们的大小关系。如果用户输入的上边界比下边界小,则交换它们的值,以确保下边界始终小于或等于上边界。 下面是这段代码的完整实现: ```python def isPalindromic(n): s = str(n) return s == s[::-1] def getInputs(): count = 0 while count < 3: try: upper = int(input("请输入区间的上边界:")) lower = int(input("请输入区间的下边界:")) if upper > lower: upper, lower = lower, upper return upper, lower except: print("输入有误,请重新输入!") count += 1 print("输入错误次数过多,程序退出!") exit() palindromic_list = [] upper, lower = getInputs() for i in range(lower, upper + 1): if isPalindromic(i): palindromic_list.append(i) total = sum(palindromic_list) print("区间[{},{}]中的回文数为:{}".format(lower, upper, palindromic_list)) print("它们的和为:{}".format(total)) ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值