1019 General Palindromic Number (20分)

该博客介绍了如何判断一个十进制数在给定的基数下是否为回文数。提供了输入输出规范及样例,并解释了如何将数转化为给定基数的表示形式。
摘要由CSDN通过智能技术生成

题目

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N < 0 N\lt0 N<0 in base b ≥ 24 b\ge24 b24, where it is written in standard notation with k + 1 k+1 k+1 digits a ​ i a​_i ai as ∑ i = 0 k ( a i b i ) \sum_{i=0}^{k}(a_ib^i) i=0k(aibi). Here, as usual, 0 ≤ a i < b 0\le a_i\lt b 0ai<b for all i i i and a ​ k a_​k ak​​ is non-zero. Then N N N is palindromic if and only if a i = a ​ k − i a_i =a_{​k−i} ai=aki for all i i i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N N N and a base b b b, you are supposed to tell if N N N is a palindromic number in base b b b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N N N and b b b, where 0 < N ≤ 1 0 9 0\lt N\le10^9 0<N109 is the decimal number and 2 ≤ b ≤ 1 0 9 2\le b\le10^9 2b109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N N N is a palindromic number in base b b b, or No if not. Then in the next line, print N N N as the number in base b b b in the form “ a k a k − 1 ⋯ a 0 a_ka_{k−1}\cdots a_0 akak1a0”. Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题目大意

给定正整数 N N N,给定基数 b b b ,将 N N N 转换成 b b b 进制数,并判断这个 b b b 进制数是否是首尾对称的,唯一需要留意的就是数据范围的问题,可以通过INT_MAX查看int的数据范围,结果为2147483647,即为 2 31 2^{31} 231(4个字节,其中有一个符号位),而题目中的 1 0 9 10^9 109int范围内,故只需用int表示即可。

代码

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

int main(){
    int n, b;
    vector<int> vec;
    scanf("%d%d", &n, &b);
    while(n){ 	//进制转换
        vec.push_back(n%b);
        n /= b;
    }
    bool flag = true;
    int t = vec.size();
    for(int i=0; i<t/2; i++)	//判断首位是否相等
        if(vec[i] != vec[t-i-1]){
            flag = false;
            break;
        }
    if(flag)
        cout<<"Yes"<<endl;
    else
        cout<<"No"<<endl;
    for(int i=vec.size()-1; i>=0; i--){
        cout<<vec[i];
        if(i)
            cout<<" ";
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值