hdoj 1708 Fibonacci String

Fibonacci String

Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 61   Accepted Submission(s) : 19

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

After little Jim learned Fibonacci Number in the class , he was very interest in it.
Now he is thinking about a new thing -- Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]....

For example :
If str[0] = "ab"; str[1] = "bc";
he will get the result , str[2]="abbc", str[3]="bcabbc" , str[4]="abbcbcabbc" …………;

As the string is too long ,Jim can't write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

Input

The first line contains a integer N which indicates the number of test cases.
Then N cases follow.
In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank.
The string in the input will only contains less than 30 low-case letters.

Output

For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format "X:N".
If you still have some questions, look the sample output carefully.
Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

Sample Input

1
ab bc 3

Sample Output

a:1
b:3
c:2
d:0
e:0
f:0
g:0
h:0
i:0
j:0
k:0
l:0
m:0
n:0
o:0
p:0
q:0
r:0
s:0
t:0
u:0
v:0
w:0
x:0
y:0
z:0

 超内存的代码:(但是不知道为什么会超内存 感觉自己已经很节省空间啦)

#include<iostream>
#include<string>
int main()
{
    using namespace std;
    int K,N;
    string str[3];
    cin>>N;
    while(N--)
    {
        int num[26]={0};
        cin>>str[0]>>str[1]>>K;
        for(int i=2;i<=K;i++)
            str[i%3]=str[(i-2)%3]+str[(i-1)%3];
        int len=str[K%3].size();
        for(int i=0;i<len;++i)
            num[str[K%3][i]-'a']++; 
        char ch='a';
        for(int i=0;i<26;i++)
        {
            cout<<ch<<":";
            cout<<num[i]<<endl;
            ch++;
        }
    }
    return 0;
}

ac代码

#include<iostream>
#include<cstdlib>
#include<cstring>
int main()
{
    using namespace std;
    char s1[35],s2[35];
    int num[50][26];
    int N,K;
    cin>>N;
    while(N--)
    {
        cin>>s1>>s2>>K;
        int len1=strlen(s1);
        int len2=strlen(s2);
        memset(num,0,sizeof(num));
        for(int i=0;i<len1;i++)
            num[0][s1[i]-'a']++;
        for(int i=0;i<len2;i++)
            num[1][s2[i]-'a']++;
        for(int i=2;i<=K;i++)
        {
            for(int j=0;j<26;j++)
                num[i][j]=num[i-2][j]+num[i-1][j];
        }
        char ch='a';
        for(int i=0;i<26;i++)
        {
            cout<<ch<<":"<<num[K][i]<<endl;
            ch++;
        }
        cout<<endl;
    }
    return 0;
}

这题自己拿到题目就一直觉得是只能用string才能做 但其实用字符数组也能做

还有就是自己一直觉得应该要把每一个字符串求出来拼接起来 但是其实只要把个数相加就好了 可以这么说 要拼接的不是字符串 而是字母的个数 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值