判断是不是一棵树(并查集)

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

翻译
树是一种众所周知的数据结构,它要么是空的(null,void,nothing),要么是一组由满足以下财产的节点之间的定向边连接的一个或多个节点。

正好有一个节点,称为根,没有定向边指向该节点。

除了根节点外,每个节点都有一条指向它的边。

从根到每个节点都有一个唯一的有向边序列。

例如,考虑下图,其中节点由圆表示,边由带箭头的线表示。前两棵是树,但最后一棵不是。

在这个问题中,您将得到由有向边连接的节点集合的几个描述。对于其中的每一个,您都要确定集合是否满足树的定义。

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1

Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree

题意.
满足树的定义,

树的定义:

1)一个具有n个结点的数,最多只有n-1个结点

2)一棵树有且只有一个入度为0的结点,并且所有结点的入度都不大于1.

#include<iostream>
using namespace std;
typedef long long ll;
const int N=5e6+7,inf=0x3f3f3f3f;
ll f[N],b[N];
ll gets(ll x) {
	if(x!=f[x])
		f[x]=gets(f[x]);
	return f[x];
}
int main() {
	ll i,j,n,m,x,y,t,cnt=1;
	while(cin>>n>>m) {
		if(n==-1&&m==-1) break;
		ll flag=0,s=0,k=0;
		while(n+m!=0) {
			if(f[n]==0)
				f[n]=n,b[k++]=n;
			if(f[m]==0)
				f[m]=m,b[k++]=m;
			int f1=gets(n);
			int f2=gets(m);
			if(f1!=f2)
				f[f1]=f2;
			else flag=1;//确定没有回环 
			cin>>n>>m;
		}
		for(i=0; i<k; i++) {
			if(f[b[i]]==b[i]) s++;// 只有一次 
			f[b[i]]=0;
			b[i]=0;
		}
		if(flag||s>1) cout<<"Case "<<cnt++<<" is not a tree."<<endl;
		else cout<<"Case "<<cnt++<<" is a tree."<<endl;
	}
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值