二叉搜索树的建立

poj 1577 Falling Leaves

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem.

A binary tree of letters may be one of two things:
It may be empty.
It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters:
Empty trees are omitted completely.
Each node is indicated by
Its letter data,
A line segment down to the left to the left subtree, if the left subtree is nonempty,
A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.

The preorder traversal of a tree of letters satisfies the defining properties:
If the tree is empty, then the preorder traversal is empty.
If the tree is not empty, then the preorder traversal consists of the following, in order
The data from the root node,
The preorder traversal of the root’s left subtree,
The preorder traversal of the root’s right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:

The root’s data comes later in the alphabet than all the data in the nodes in the left subtree.

The root’s data comes earlier in the alphabet than all the data in the nodes in the right subtree.

The problem:

Consider the following sequence of operations on a binary search tree of letters

Remove the leaves and list the data removed
Repeat this procedure until the tree is empty
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree
在这里插入图片描述

by removing the leaves with data

BDHPY
CM
GQ
K

Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.
Input
The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters.

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk (’*’).

The last data set is followed by a line containing only a dollar sign (’$’). There are no blanks or empty lines in the input.
Output
For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

思路

二叉搜索树(左节点比自己大右节点比自己小或反过来)的权值确定位置也定
因为样例节点的顺序按从左到右拆除端点的顺序给的,所以直接在端点处建节点就行
下面展示一些 内联代码片
Sample Input

BDHPY
CM
GQ
K
*
AC
B
$

Sample Output
KGCBDHQMPY
BAC

#include<stdio.h>
#include<string.h>
struct tree
{
	int left,right;/*记录此节点的左右节点信息在数组q中的位置*/
	char c;/*此节点的字母*/
} q[110000];
int tail=-1;
char a[1000][1100];
void add(int x,char ch)
{
	if(ch<q[x].c)/*判断在此节点的左边还是右边*/
	{
		if(q[x].left==0)/*判断有没有左节点*/
		{
			q[++tail].c=ch;/*左节点信息加到数组的队尾*/
			q[x].left=tail;/*让此节点记住自己的左节点的位置tail*/
			return;
		}
		else
			add(q[x].left,ch);/*有左节点就继续跟左节点比*/
	}
	if(ch>q[x].c)
	{
		if(q[x].right==0)
		{
			q[++tail].c=ch;
			q[x].right=tail;
			return;
		}
		else
			add(q[x].right,ch);
			return;
	}
}
void qianxu(int x)
{
	printf("%c",q[x].c);
	if(q[x].left)
	qianxu(q[x].left);
	if(q[x].right)
	qianxu(q[x].right);
}
int main()
{
	int j,i,k=-1,L;
	while(1)
	{
		scanf("%s",a[++k]);
		getchar();
		if(a[k][0]=='$'||a[k][0]=='*')
		{
			for(i=k-1; i>=0; i--)
			{
				L=strlen(a[i]);
				for(j=0; j<L; j++)
				{
					add(0,a[i][j]);
    /*每次都从最顶点处通过比较从而确定大致在左还是右,然后通过递归逐渐确定范围*/
				}
			}
		//	printf("**%c**",q[1].c);
			qianxu(0);
			printf("\n");
			if(a[k][0]=='$')
			break;
			k=-1;
			tail=-1;
			memset(a,'\0',sizeof(a));
			memset(q,0,sizeof(q));
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值