广搜(模板题)

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

求最短,最小时一定要用广搜,广搜搜索到即为最小。

#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int book[1001000];
int n,k;
struct bu
{
	int x,t;
};
int bfs()
{
	queue<bu>que;
	bu ss;
	ss.x=n;
	ss.t=0;
	book[ss.x]=1;
	que.push(ss);
	while(!que.empty())
	{
		ss=que.front();
		que.pop();
		if(ss.x==k)
		{
			return ss.t;
		}
		
		for(int i=0;i<=2;i++)
		{
			int tx;
			bu du;
			if(i==0) tx=ss.x+1;
			else if(i==1) tx=ss.x-1;
			else if(i==2) tx=2*ss.x;
			if(tx<0||tx>100000)
				continue;
			if(book[tx]==1)
				continue;
			
			book[tx]=1;
			du.x=tx;
			du.t=ss.t+1;
			que.push(du);
		}
		
	}
}
int main()
{
	while(~scanf("%d%d",&n,&k))	
	{
		int ans;
		memset(book,0,sizeof(book));
		ans=bfs();
		cout<<ans<<endl;
	}
	return 0;	
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值