MGRE实验

 第一步:IP地址规划

PC地址

设备

地址

网关

PC1

192.168.1.2/24

192.168.1.1/24

PC2

192.168.2.2/24

192.168.2.1/24

PC3

192.168.3.2/24

192.168.3.1/24

设备地址

 

第二步:配置IP地址

R1配置

[R1]interface g0/0/0

[R1-GigabitEthernet0/0/0]ip address 192.168.1.1 24

[R1]interface s4/0/0

[R1-Serial4/0/0]ip address 15.1.1.1 24

 R3配置

[R3]interface g0/0/0

[R3-GigabitEthernet0/0/0]ip address 192.168.2.1 24

[R3]interface s4/0/0

[R3-Serial4/0/0]ip address 25.1.1.1 24

R4配置 

[R4]interface g0/0/0

[R4-GigabitEthernet0/0/0]ip address 192.168.3.1 24

[R4]interface s4/0/0

[R4-Serial4/0/0]ip address 35.1.1.1 24

R2配置 

[R2]interface Serial3/0/0

[R2-Serial3/0/0]ip address 35.1.1.2 255.255.255.0

[R2]interface Serial4/0/0

[R2-Serial4/0/0]ip address 15.1.1.2 255.255.255.0

[R2]interface Serial4/0/1

[R2-Serial4/0/1]ip address 25.1.1.2 255.255.255.0

第三步:HDLC封装(R1—R2)

R1上的配置

[R1]interface Serial 4/0/0  
[R1-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N] :y
Jul 23 2023 12:36:13-08:00 R1 %%01IFNET/4/CHANGE_ENCAP(l)[0]:The user performed 
the configuration that will change the encapsulation protocol of the link and th
en selected Y. 

R2上的配置 

[R2]interface Serial 4/0/0  
[R2-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N] :y
Jul 23 2023 12:37:04-08:00 R2 %%01IFNET/4/CHANGE_ENCAP(l)[2]:The user performed
 the configuration that will change the encapsulation protocol of the link and t
hen selected Y.  

第四步:ppp封装,pap认证(R2—R3)

R2(ISP),主认证方

[R2]aaa 
[R2-aaa]local-user huahua password cipher huahua
Info: Add a new user. 
[R2-aaa]local-user huahua service-type ppp
[R2-aaa]q 
[R2]interface Serial 4/0/1
[R2-Serial4/0/1]link-protocol ppp
[R2-Serial4/0/1]ppp authentication-mode pap

R3 被认证方

[R3]interface Serial 4/0/0
[R3-Serial4/0/0]link-protocol ppp   
[R3-Serial4/0/0]ppp pap local-user huahua password cipher huahua

第五步:ppp封装,chap认证(R2—R4) 

 R2(ISP),主认证方

[R2]aaa
[R2-aaa]local-user huawei password cipher huawei
Info: Add a new user.  
[R2-aaa]local-user huawei service-type ppp
[R2-aaa]q 
[R2]interface Serial 3/0/0
[R2-Serial3/0/0]link-protocol ppp   
[R2-Serial3/0/0]ppp authentication-mode chap 

R4被认证方

[R4]interface Serial 4/0/0
[R4-Serial4/0/0]link-protocol ppp
[R4-Serial4/0/0]ppp chap user huawei
[R4-Serial4/0/0]ppp chap password cipher huawei

第六步:MGRE环境 

 R1、R3、R4向R2(ISP)缺省路由 

[R1]ip route-static 0.0.0.0 0 15.1.1.2

[R3]ip route-static 0.0.0.0 0 25.1.1.2

[R4]ip route-static 0.0.0.0 0 35.1.1.2

R1上的配置 

 [R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 10.1.1.1 24
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R1-Tunnel0/0/0]source 15.1.1.1
Jul 23 2023 13:32:54-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 

[R1-Tunnel0/0/0]nhrp entry multicast dynamic 
[R1-Tunnel0/0/0]nhrp network-id 100

R3上的配置  

[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 10.1.1.3 24   
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/0]source s4/0/0
Jul 23 2023 13:39:19-08:00 R3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state.   
[R3-Tunnel0/0/0]nhrp network-id 100
[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register 

R4上的配置  

[R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.4 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp 
[R4-Tunnel0/0/0]source s4/0/0
Jul 23 2023 13:46:21-08:00 R4 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state.   
[R4-Tunnel0/0/0]nhrp network-id 100    
[R4-Tunnel0/0/0]nhrp entry 10.1.1.1 15.1.1.1 register 

第七步:RIP宣告

R1上的配置

[R1]rip 1
[R1-rip-1]version 2
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0
[R1-rip-1]q
[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]undo rip split-horizon 

R3上的配置

[R3]rip 1
[R3-rip-1]version 2
[R3-rip-1]network 192.168.2.0
[R3-rip-1]network 10.0.0.0 

R4上的配置

[R4]rip 1 
[R4-rip-1]version 2
[R4-rip-1]network 192.168.3.0
[R4-rip-1]network 10.0.0.0

第八步:NAT地址转换

R1上的配置 

[R1]acl 2000
[R1-acl-basic-2000]rule 1 permit source any 
[R1-acl-basic-2000]q
[R1]interface Serial 4/0/0   
[R1-Serial4/0/0]nat outbound 2000

R3上的配置

[R3]acl 2000 
[R3-acl-basic-2000]rule 1 permit source any 
[R3-acl-basic-2000]q
[R3]int s4/0/0  
[R3-Serial4/0/0]nat outbound 2000

R4上的配置

[R4]acl 2000
[R4-acl-basic-2000]rule 1 permit source any 
[R4-acl-basic-2000]q
[R4]int s4/0/0 
[R4-Serial4/0/0]nat outbound 2000 

第九步:连通性测试

PC2->PC3 

 PC2->PC1

 PC1->PC3

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

孤冢清风666

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值