7-1 建立二叉搜索树并查找父结点

按输入顺序建立二叉搜索树,并搜索某一结点,输出其父结点。

输入格式:

输入有三行: 第一行是n值,表示有n个结点; 第二行有n个整数,分别代表n个结点的数据值; 第三行是x,表示要搜索值为x的结点的父结点。

输出格式:

输出值为x的结点的父结点的值。 若值为x的结点不存在,则输出:It does not exist. 若值为x的结点是根结点,则输出:It doesn't have parent.

输入样例:

2
20
30
20

输出样例:

It doesn't have parent.

###输入样例:

2
20
30
30

输出样例:

20

 相关文章:

7-4 二叉搜索树的最近公共祖先 【题目解析】icon-default.png?t=M0H8https://blog.csdn.net/qq_61351908/article/details/122620280上述文章内容较全,若上述能够理解,本题应该不是问题。

完整代码: 

#include <iostream>
#include <stdlib.h>
using namespace std;

typedef struct BiTNode
{
    int data;
    struct BiTNode *lchild,*rchild;
}BiTNode,*BiTree;

BiTree bstSearch(BiTree T,BiTree &parent,int data)
{
    if(T){
        if(T->data == data)
        {
            return T;
        }
        else if(data < T->data)
        {
            parent = T;
            return bstSearch(T->lchild,parent,data);
        }
        else {
            parent = T;
            return bstSearch(T->rchild,parent,data);
        }
    }else return NULL;
}

void bstInsert(BiTree &T,int data)
{
    if(T==NULL){
        T = (BiTree)malloc(sizeof(BiTNode));
        T->data = data;
        T->lchild = NULL;
        T->rchild = NULL;
    }else if(T->data == data)
        return;
    else if(data < T->data)
        bstInsert(T->lchild,data);
    else bstInsert(T->rchild,data);
}

int main()
{
    BiTree T = NULL,parent = NULL,child = NULL;
    int n,x;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>x;
        bstInsert(T,x);
    }

    cin>>x;
    child = bstSearch(T,parent,x);
    if(child == NULL)
    {
        cout<<"It does not exist."<<endl;
    }else if(parent==NULL){
        cout<<"It doesn't have parent."<<endl;
    }else{
        cout<<parent->data<<endl;
    }


}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

亮子i_12138

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值