An organic compound is any member of a large class of chemical compounds whose molecules contain carbon. The molar mass of an organic compound is the mass of one mole of the organic compound. The molar mass of an organic compound can be computed from the standard atomic weights of the elements. When an organic compound is given as a molecular formula, Dr. CHON wants to find its molar mass. A molecular formula, such as C3H4O3, identifies each constituent element by its chemical symbol and indicates the number of atoms of each element found in each discrete molecule of that compound. If a molecule contains more than one atom of a particular element, this quantity is indicated using a subscript after the chemical symbol. In this problem, we assume that the molecular formula is represented by only four elements, ‘C’ (Carbon), ‘H’ (Hydrogen), ‘O’ (Oxygen), and ‘N’ (Nitrogen) without parentheses. The following table shows that the standard atomic weights for ‘C’, ‘H’, ‘O’, and ‘N’. Atomic Name Carbon Hydrogen Oxygen Nitrogen Standard Atomic Weight 12.01 g/mol 1.008 g/mol 16.00 g/mol 14.01 g/mol For example, the molar mass of a molecular formula C6H5OH is 94.108 g/mol which is computed by 6 × (12.01 g/mol) + 6 × (1.008 g/mol) + 1 × (16.00 g/mol). Given a molecular formula, write a program to compute the molar mass of the formula. Input Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case is given in a single line, which contains a molecular formula as a string. The chemical symbol is given by a capital letter and the length of the string is greater than 0 and less than 80. The quantity number n which is represented after the chemical symbol would be omitted when the number is 1 (2 ≤ n ≤ 99). Output Your program is to write to standard output. Print exactly one line for each test case. The line should contain the molar mass of the given molecular formula.
Sample Input
4
C
C6H5OH
NH2CH2COOH
C12H22O11
Sample Output
12.010
94.108
75.070
342.29
*********************************************************************************************************
本人紫书的第八道题目了,此题处于入门题的位置,但个人感觉这道题的难度还真不低(可能是因为俺现在太菜了,,)
#include <stdio.h>
#include <string.h>
#include <ctype.h>
int main ()
{
int n,i;
double g;
char a[100];
scanf("%d",&n);
while(n--)
{
double sum=0;
int t=0;
scanf("%s",a);
int len=strlen(a);
for(i=0;i<len;i++)
{
//if(isdigit(a[i])) continue;
//找出元素的相对原子质量
if(isalpha(a[i]))
{
if(a[i]=='C') g=12.01;
if(a[i]=='H') g=1.008;
if(a[i]=='O') g=16.00;
if(a[i]=='N') g=14.01;
}
int k=i+1;
//计算出原子的系数
if(isdigit(a[k]))//此处循环正是不好想的地方,既要计算出系数,又要保证i的更新
{
t=0;
for( ;isdigit(a[k]);k++)
{
t=t*10+(a[k]-'0');
}
i=k-1;//保证i变量的正确更新(还有一种方法就是用上面注释掉的那句代码)
}
else t=1;
sum+=g*t;
}
printf("%.3lf\n",sum);
}
}
这道题卡了俺一晚上,计算系数跟循环次数i的关系一直没法维持好两者的关系,在查找了一些网友的代码后,才得以解决这个问题,其中注释掉的是网友的方法,i=k-1;更新循环次数变量是我的方法。