uva 10422 - Knights in FEN

Problem D

Knights in FEN

Input: standard input

Output: standard output

Time Limit: 10 seconds

 

There are black and white knights on a 5 by 5 chessboard. There are twelve of each color, and there is one square that is empty. At any time, a knight can move into an empty square as long as it moves like a knight in normal chess (what else did you expect?).

Given an initial position of the board, the question is: what is the minimum number of moves in which we can reach the final position which is:

Input

First line of the input file contains an integer N (N<14) that indicates how many sets of inputs are there. The description of each set is given below:

Each set consists of five lines; each line represents one row of a chessboard. The positions occupied by white knights are marked by 0 and the positions occupied by black knights are marked by 1. The space corresponds to the empty square on board.

There is no blank line between the two sets of input.

The first set of the sample input below corresponds to this configuration:

Output

For each set your task is to find the minimum number of moves leading from the starting input configuration to the final one. If that number is bigger than 10, then output one line stating

Unsolvable in less than 11 move(s).

 

otherwise output one line stating

Solvable in n move(s).

where n <= 10.

The output for each set is produced in a single line as shown in the sample output.

Sample Input

2
01011
110 1
01110
01010
00100
10110
01 11
10111
01001
00000

Sample Output

Unsolvable in less than 11 move(s).
Solvable in 7 move(s).

(Problem Setter: Piotr Rudnicki, University of Alberta, Canada)

 

 

A man is as great as his dreams.”

虽然正统的做法就是bfs+hash判重复,但是题目给了最大步数限制,用dfs+减枝过,

最多4^11,由于5*5每次不一定扩展4个方向,数据规模不大没必要要写判重复,我们只需要每次不走回头路,这样虽然还是存在重复的情况但是已经减少很多不必要的搜索了,0.008sAC

#include<stdio.h>
#include<string.h>
int a[5][5],move[8][2]={{-1,-2},{-1,2},{-2,1},{-2,-1},{2,1},{2,-1},{1,-2},{1,2}},
    b[5][5]={{1,1,1,1,1},{0,1,1,1,1},{0,0,2,1,1},{0,0,0,0,1},{0,0,0,0,0}},min;
int dfs(int x,int y,int step,int way)
{int i,j,X,Y,sum=0,t;
 if (step>=min) return 0;
 for (i=0;i<5;i++)
 for (j=0;j<5;j++)
 if (a[i][j]!=b[i][j]) ++sum;
 if (sum==0) {if (step<min) min=step; return 0;}
 if ((sum+1)/2+step>=min) return 0; //SUM表示与目标状态不同的位置个数,则最少需要(移动一次最多2个位置与目标状态相同)sum/2+sum%2=(sum+1)/2步才能变为目标状态
 for (i=0;i<8;i++)
 {X=x+move[i][0];
  Y=y+move[i][1];
  if ((X>=0)&&(X<5)&&(Y>=0)&&(Y<5)&&(way+i!=7)) //初始化move时将相反跳法的下标和为7,这样就可以每次避免走回头路省略判重过程
  {t=a[x][y];a[x][y]=a[X][Y];a[X][Y]=t;
   dfs(X,Y,step+1,i);
   t=a[x][y];a[x][y]=a[X][Y];a[X][Y]=t;
  }
 }
}
int main()
{int i,j,x,y,n;
 char s[6];
 scanf("%d\n",&n);
 while (n--)
 {
  for (i=0;i<5;i++)
  {gets(s);
   for (j=0;s[j]!='\0';j++)
   if (s[j]==' ') {a[i][j]=2;x=i;y=j;}
             else a[i][j]=s[j]-'0';
  }
  min=11;
  dfs(x,y,0,8);
  if (min==11) printf("Unsolvable in less than 11 move(s).\n");
  else printf("Solvable in %d move(s).\n",min);
 }
 return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值