题目描述
送人玫瑰手有余香,小明希望自己能带给他人快乐,于是小明在每个好友生日的时候发去一份生日祝福。小明希望将自己的通讯录按好友的生日排序排序,这样就查看起来方便多了,也避免错过好友的生日。为了小明的美好愿望,你帮帮他吧。小明的好友信息包含姓名、出生日期。其中出生日期又包含年、月、日三部分信息。输入n个好友的信息,按生日的月份和日期升序输出所有好友信息。
输入
首先输入一个整数n(1<=n<=10),表示好友人数,然后输入n行,每行包含一个好友的信息:姓名(不超过8位),以及三个整数,分别表示出生日期的年月日。
输出
按过生日的先后(月份和日期)输出所有好友的姓名和出生日期,用空格隔开,出生日期的输出格式见输出样例。
样例输入
3
Zhangling 1985 2 4
Wangliang 1985 12 11
Fangfang 1983 6 1
样例输出
Zhangling 1985-02-04
Fangfang 1983-06-01
Wangliang 1985-12-11
#include<stdio.h>
struct student
{
char name[20];
int year;
int mouth;
int day;
};
int main()
{
struct student std[10];
int n = 0;
scanf("%d", &n);
for (int i = 0; i < n; i++)
{
scanf("%s %d %d %d", &std[i].name, &std[i].year, &std[i].mouth, &std[i].day);
}
for (int i = 0; i < n-1; i++)
{
for (int j = i; j < n-1; j++)
{
if (std[i].mouth > std[j + 1].mouth)
{
struct student temp = std[i];
std[i] = std[j + 1];
std[j + 1] = temp;
}
else if (std[i].mouth == std[j + 1].mouth && std[i].day > std[j+1].day)
{
struct student temp = std[i];
std[i] = std[j + 1];
std[j + 1] = temp;
}
}
}
for (int i = 0; i < n; i++)
{
printf("%s %d-%02d-%02d\n", std[i].name, std[i].year, std[i].mouth, std[i].day);
}
return 0;
}