HDU1040插入排序二分优化

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 98038    Accepted Submission(s): 41120


 

Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
 
 
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
 
 
1 2 3 1 2 3 4 5 6 7 8 9
 

Author
lcy
分析这是一道标准的排序水题我们可以拿来练习插入排序,由于原来插入排序过于慢,所以决定用二分法对其进行优化
原来我们的插入排序是读入一个新的数然后再与前面数字进行一一比较最后插入,这里我们采取二分查找对其优化,查找到插入的位置,话不多说看代码
#include<stdio.h>
int t,n,i,j,k,m,l,r,pos,tmp,mid;
int a[1005];
int main(){
    scanf("%d",&t);
    for(i=1;i<=t;i++){
        scanf("%d",&m);
        scanf("%d",&a[1]);
        for(j=2;j<=m;j++){
            scanf("%d",&a[j]);
            l=1; 
            r=j-1;
            tmp=a[j];
            while(l<=r){
                mid=(l+r)/2;//mid=(l&r)+((l^r)>>1);最好打不懂的看文章末我的链接,另一个博客
                if(a[mid]>tmp){
                    r=mid-1;//注意二分这里要打减少一,下面要打加一,要不会爆时间 
                    pos=mid;
                }
                else if(a[mid]<=tmp){
                    l=mid+1;
                    pos=mid+1;
                }
            }
            for(k=j-1;k>=pos;k--){
                a[k+1]=a[k];
            }
            a[pos]=tmp;
        }
        printf("%d",a[1]);
        for(j=2;j<=m;j++){
            printf(" %d",a[j]);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值