Acwing.802 区间和(离散化&前缀和)

题目

假定有一个无限长的数轴,数轴上每个坐标上的数都是0。
现在,我们首先进行n次操作,每次操作将某一位置x上的数加c。
近下来,进行m次询问,每个询问包含两个整数l和r,你需要求出在区间[l, r]之间的所有数的和。

输入格式

第一行包含两个整数n和m。
接下来n行,每行包含两个整数x和c。
再接下里m行,每行包含两个整数l和r。

输出格式

共m行,每行输出一个询问中所求的区间内数字和。

数据范围

—109<x≤109,1 ≤n, m ≤ 105,-109<l≤r ≤109,—10000<c <10000

  • 输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8
  • 输出样例:
8
0
5

题解

import java.util.*;

/**
 * @author akuya
 * @create 2023-06-22-19:23
 */
public class Discretization {
    static int N=300010;
    static int n,m;
    static int a[]=new int[N];
    static int s[]=new int[N];
    static List<Integer> alls=new ArrayList<>();

    static Map<Integer,Integer> add=new HashMap<>();
    static Map<Integer,Integer> query=new HashMap<>();

    public static void main(String[] args) {
        Scanner scanner=new Scanner(System.in);
        n=scanner.nextInt();
        m=scanner.nextInt();
        for(int i=0;i<n;i++){
            int x,c;
            x=scanner.nextInt();
            c=scanner.nextInt();
            add.put(x,c);
            alls.add(x);
        }

        for(int i=0;i<m;i++){
            int l,r;
            l=scanner.nextInt();
            r=scanner.nextInt();
            query.put(l,r);
            alls.add(l);
            alls.add(r);
        }
//list 排序
        alls.sort(new Comparator<Integer>() {
            @Override
            public int compare(Integer o1, Integer o2) {
                return o1-o2;
            }
        });
//list 去重
        HashSet set=new HashSet(alls);
        alls.clear();
        alls.addAll(set);

        //处理插入
        for(Map.Entry<Integer,Integer> entry: add.entrySet()){
            int x=find(entry.getKey());
            a[x]+=entry.getValue();

        }

        //预处理前缀和
        for(int i=1;i<=alls.size();i++){
            s[i]=s[i-1]+a[i];
        }

        //处理询问
        for(Map.Entry<Integer,Integer> entry:query.entrySet()){
            int l=find(entry.getKey()),r=find(entry.getValue());
            System.out.println(s[r]-s[l-1]);
        }



    }

    public static int find(int x){
        int l=0;
        int r= alls.size()-1;
        while(l<r){
            int mid =l+r>>1;
            if(alls.get(mid) >=x)r=mid;
            else l=mid+1;
        }

        return r+1;

    }

}

思路

第一次接触离散化可能看代码都有点懵逼,我也一样,离散化运用于值域很大,但是数的个数缺很小的题,例如本题范围为10-9 ——109次方,数的个数大小却只有105,范围过大无法创建空间,则用离散化思想,将所有会用到的点(题中包括插入的点,以及范围点)离散化,通过find函数找到离散化之后的位置与值。最后通过前缀和求得区间和。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值