HDU 7053 Smzzl with Tropical Taste

Problem Description

A boy, whose ID is smzzl, loves drinking Black Ice Tea(BIT), especially the tropical taste one.

The shop owner knows that, and she prepares a swimming pool so that there would be enough space for her to store BIT. When the boy knows that the owner prepared a swimming pool, he starts to drink in the swimming pool. While the owner is pouring BIT into the swimming pool, the boy is drinking it, too.

Assuming that there are V liters of BIT in the swimming pool, the speed the owner pours BIT is qV liters per second, and the speed the boy drinks BIT is pV liters per second. Note that V changes as the time goes.

Now, the owner wants to know whether the following statement is true:

For any G>0, there exists a T>0, for any t>T, the boy drinks more than G liters of BIT after t seconds.

Input

The input consists of multiple test cases.

The first line contains an integer T (1≤T≤100) -- the number of test cases.

For each test case, there are two decimals p,q (0<p,q<104, they have at most 4 decimal places) in a single line, p,q are mentioned in the statement. You may regard the initial volume of BIT as 1 liter, and the swimming pool can contain infinity volume of BIT.

Output

For each test case, output a sentence in a single line.

If the statement is true, output 'N0 M0R3 BL4CK 1CE TEA!'.

If the statement is false, output 'ENJ0Y YOURS3LF!'

Sample Input

2 1.1 2.2 2.05 1.4

Sample Output

N0 M0R3 BL4CK 1CE TEA! ENJ0Y YOURS3LF!

题意:给定一个无限容量的水池,以及店家向水池中加茶的速度和smzzl喝茶的速度,问是否对于任意体积G>0,总存在一个时刻T对于任何t>T,在t时刻smzzl喝的茶的体积总是大于G;

思路:只要店家添加茶的速度不小于smzzl喝茶的速度即水池里面的茶不会变少那么就肯定存在这样的时刻T;

ac代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		double p,q;
		cin>>p>>q;
		if(q>=p)
			puts("N0 M0R3 BL4CK 1CE TEA!");
		else 
			puts("ENJ0Y YOURS3LF!");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值