HDU 4608 I-number

Problem Description

The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1. y>x;
2. the sum of each digit of y(under base 10) is the multiple of 10;
3. among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.

 

Input

An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 105.

 

Output

Output the I-number of x for each query.

 

Sample Input

 
 

1 202

 

Sample Output

 
 

208

思路:直接利用大数加法,每次使其加一,然后检查是不是已经符合题目条件,完全不用担心超时的问题,理论上运算不会超过20次加法,每次最坏情况也就是1e5,因此不会超时

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int N=100010;

int a[N],n;
char s[N];

void add()
{
	a[n-1]++;
	int i=n-1;
	while(a[i]>9)
	{
		a[i--]=0;
		a[i]++;
	}
}

bool check()
{
	int sum=0;
	for(int i=0;i<n;i++)
		sum+=a[i];
	return sum%10==0;
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		memset(a,0,sizeof a);
		cin>>s+1;
		s[0]='0';
		n=strlen(s);
		for(int i=0;i<n;i++)
			a[i]=s[i]-'0';
		do{
			add();
		}while(!check());
		bool f=0;
		for(int i=0;i<n;i++)
		{
			if(a[i])
				f=1;
			if(f)
				printf("%d",a[i]);
		}
		puts("");
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值