HDU 4722 Good Numbers

Problem Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.

 

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).

 

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.

 

Sample Input

 
 

2 1 10 1 20

 

Sample Output

 
 

Case #1: 0 Case #2: 1

 

Hint


The answer maybe very large, we recommend you to use long long instead of int.

思路:通过打表输出发现每十个数之间必有一个符合要求的数字,于是只要从a开始玩后并且从b开始往前找到各自遇到的第一个符合要求的数字,然后除以10再相减即可得到答案,注意无解的情况

AC代码

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

#define ll long long

int check(ll a)
{
	ll sum=0;
	while(a)
	{
		sum+=a%10;
		a/=10;
	}
	return sum%10;
}

int main()
{
	ll a,b;
	int t;
	cin>>t;
	for(int k=1;k<=t;k++)
	{
		cin>>a>>b;
		while(check(a))a++;
		while(check(b))b--;
		
		ll res;
		if(a>b)res=0;
		else res=b/10-a/10+1;
		printf("Case #%d: %lld\n",k,res);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Double.Qing

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值