PAT甲级1020 树的构造 DFS

1020 Tree Traversals

分数 25

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

解法:由后序和中序构造树

参考文献:东哥带你刷二叉树(构造篇) | labuladong 的算法笔记

代码:

#include<bits/stdc++.h>
using namespace std;
int n;
int post[40],in[40];
vector<int> ans;
struct TreeNode{
    int val;
    TreeNode *l,*r;
    TreeNode(int val){
        this->val = val;
    }
};

TreeNode* gouzao(int (&in)[40],int instart,int inend,int (&post)[40],int poststart,int postend){
    if(poststart>postend) return nullptr;
    TreeNode *root = new TreeNode(post[postend]);
    int index;
    for(int i=instart;i<=inend;i++){
        if(in[i]==post[postend]){
            index = i;
            break;
        }
    }
    int charzhil = index - instart;
    root->l = gouzao(in,instart,index-1,post,poststart,poststart+charzhil-1);
    root->r = gouzao(in,index+1,inend,post,poststart+charzhil,postend-1);
    return root;
}


int main(){
    cin>>n;
    for(int i=0;i<n;i++) cin>>post[i];
    for(int i=0;i<n;i++) cin>>in[i];
    
    TreeNode *root = gouzao(in,0,n-1,post,0,n-1);
    queue<TreeNode*> q;
    q.push(root);
    
    while(!q.empty()){
        TreeNode* cur = q.front();
        q.pop();
        ans.push_back(cur->val);
        if(cur->l!=nullptr)q.push(cur->l);
        if(cur->r!=nullptr)q.push(cur->r);
    }
    for(int i=0;i<ans.size();i++){
        if(!i) cout<<ans[0];
        else cout<<" "<<ans[i];
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值