PAT甲级1107 并查集

1107 Social Clusters

分数 30

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki​: hi​[1] hi​[2] ... hi​[Ki​]

where Ki​ (>0) is the number of hobbies, and hi​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

代码长度限制

16 KB

时间限制

1200 ms

内存限制

64 MB

代码

//将开启爱好圈子的第一个人作为标杆,相同爱好的人有相同的标杆,相同人的不同爱好有相同的标杆
#include<bits/stdc++.h>
using namespace std;
int father[1001]={0},cluster[1001]={0};
vector<int> isroot(1001,0);
int n;

int findfather(int x){
    if(x!=father[x]) father[x] = findfather(father[x]);
    return father[x];
}
void _union(int x,int y){
    int xfather = findfather(x);
    int yfather = findfather(y);
    if(xfather==yfather) return;
    father[xfather] = yfather;
}

int main(){
    cin>>n;
    for(int i=1;i<=n;i++) father[i] = i;
    for(int i=1;i<=n;i++){
        int k;
        cin>>k;
        getchar();
        for(int j=0;j<k;j++){
            int h;
            cin>>h;
            if(cluster[h]==0) cluster[h] = i;
            _union(i,findfather(cluster[h]));
        }
    }
    for(int i=1;i<=n;i++) isroot[findfather(i)]++;
    sort(isroot.begin(),isroot.end(),greater<int>());
    int sum=0;
    for(int i=0;i<n;i++){
        if(isroot[i]!=0) sum++;
        else break;
    }
    cout<<sum<<endl;
    for(int i=0;i<sum;i++){
        if(!i) cout<<isroot[i];
        else cout<<" "<<isroot[i];
    }
    
}
  • 7
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值