PAT甲级 1074静态链表

1074 Reversing Linked List

分数 25

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤105) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include<bits/stdc++.h>
using namespace std;
struct node{
    int xz,data,next;
};
node a[100001];
vector<node> v;

int main(){
    int head,n,k;
    cin>>head>>n>>k;
    int from,to,d;
    for(int i=0;i<n;i++){
        cin>>from>>d>>to;
        a[from].xz = from;
        a[from].next = to;
        a[from].data = d;
    }
    
    int p=head;
    while(a[p].next!=-1){
        v.push_back(a[p]);
        p=a[p].next;
        
    }
    v.push_back(a[p]);
    
    for(int i=0;i<v.size();i+=k){
        if(i+k<=v.size()) reverse(v.begin()+i,v.begin()+i+k);
    }
    for(int i=0;i<v.size();i++){
        if(i+1<v.size())v[i].next=v[i+1].xz;
        else v[i].next = -1;
    }
    for(int i=0;i<v.size()-1;i++){
        printf("%05d %d %05d\n",v[i].xz,v[i].data,v[i].next);
    }
    printf("%05d %d %d\n",v[v.size()-1].xz,v[v.size()-1].data,v[v.size()-1].next);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值