PAT 1004 Counting Leaves (C++)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:给出n个点个m个有孩子的节点,问每一层无孩节点的个数

测试点2是节点就只有根节点(n=1,m=0),输出1

解析:我们先读入每个有孩子的节点,然后开一个sd[ i ]数组来记录第 i 节点在哪一层,因为根节点在第1层,因此我们可以遍历所有点,他们的孩子的深度就是父节点深度+1,然后利用广搜来进行答案记录

#include <stdio.h>
#include <vector>
#include <queue>
using namespace std;
const int N=105;
vector<int> v[N];
int g[N],n,m,sd[N];//g记录每个深度无孩节点的个数,sd[i]记录第i节点所在的层数
void solve()
{
    queue<int> q;
    q.push(1);
    while(q.size())
    {
        int u=q.front();
        q.pop();
        for(int i=0;i<v[u].size();i++)
        {
            int j=v[u][i];
            if(v[j].size()==0) g[sd[j]]++;//对应节点没有孩子,对应深度满足条件节点个数+1
            else q.push(j);
        }
    }
}
int main()
{
    scanf("%d%d",&n,&m);
    sd[1]=1;//根节点在深度1
    int maxn=0;//记录最大深度,为后输出
    while(m--)
    {
        int fa,k,p;
        scanf("%d%d",&fa,&k);
        while(k--)
        {
            scanf("%d",&p);
            v[fa].push_back(p);//父节点存储儿子
        }
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<v[i].size();j++)
        {
            sd[v[i][j]]=sd[i]+1;//儿子深度=父亲深度+1
            maxn=max(maxn,sd[i]+1);//更新最大深度
        }
    }
    solve();
    for(int i=1;i<=maxn;i++)
    {
        if(i!=1) printf(" ");
        printf("%d",g[i]);
    }
    if(maxn==0) printf("1");//特判,节点就只有根节点,输出1
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值