ZCMU--1464: Similar Word

Description

It was a crummy day for Lur. He failed to pass to the CET-6 (College English Test Band-6). Looking back on how it was in last year gone by, he gradually noticed he had fled too many English Lessons. But he determines to memorize words on his bed ,not in the classroom. You know, it is not that easy to pass the test mainly because the large amount of born words. Lur is intelligent on games , never English. He cann't learn the similar words by heart. He always choose to select a word to learn from the similar words . For him, two words are similar if and only if one word can equal to the other by multiple cyclic shift(at least 1). For example, "car" and "arc" are similar words, while "car" and "rca" are also similar words . To save more time to play games,Lur want to know wether two words are similar words faster, he asks you to write a program to tell him ,can you help him ?

Input

There are multiple test cases. Each case contains two lines. Each line contains a word, W. You can assume that length(W)<=10^5 . Ended by EOF.

Output

Output “yes” in a single line if two words are similar,otherwise you should output  “no” in a single line.

Sample Input

car
arc
car
cra
car
car

Sample Output

yes
no
no

解析:如果一个字符串a能通过循环变成字符串b,其实可以把a字符串延长一倍,如果字符串b在a中出现过,那么就可以证明字符串a能通过循环变成字符串b,对于第二步利用KMP判断即可。
 

注意点:因为题目要求至少换一位,因此我们得判断是否KMP匹配成功是否是第一位,还需要判断两者字符串初始长度是否相同,如果不相同那么肯定就不符了。

#include <stdio.h>
#include <string.h>
#define N 200005//因为延长,需要开两倍
char a[N],b[N];
int ne[N];
int main()
{
    while(~scanf("%s%s",a+1,b+1))
    {
    	int m=strlen(a+1),n=strlen(b+1),x=m;
    	if(strcmp(a+1,b+1)==0||n!=m)//特判
    	{
    		printf("no\n");
    		continue;
    	}
    	for(int i=1;i<=m;i++) a[++x]=a[i];//延长操作
    	m*=2;
    	//下面就是KMP模板操作
    	for(int i=2,j=0;i<=n;i++)
    	{
	        while(j&&b[i]!=b[j+1]) j=ne[j];
	        if(b[i]==b[j+1]) j++;
	        ne[i]=j;
	    }
	    int f=0;//是否有解
	    for(int i=1,j=0;i<=m;i++)
	    {
	        while(j&&a[i]!=b[j+1]) j=ne[j];
	        if(a[i]==b[j+1]) j++;
	        if(j==n){
	            if(i-n!=0)//特判是否存在非第一位匹配成功的位置
	            {
	            	f=1;
	            	break;
	            }
	            j=ne[j];
	        }
	    }
	    if(f) printf("yes\n");
	    else printf("no\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值