网络类型实验

1.R2为ISP,其上只能配置IP地址
2.R1-R2之间为HDLC封装
3.R2-R3之间为PPP封装,pap认证,R2为主认证方
4.R2-R4之间为PPP封装,chap认证,R2为主认证方
5.R1,R2,R3建构MGRE环境,仅R1IP地址固定
6.内网使用RIP获取路由,所有PC可以互相访问,并且可以访问R2的环回。

R2:

[R2]int s4/0/0   
[R2-Serial4/0/0]link-protocol hdlc 
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
 [R2-Serial4/0/0]ip address 12.1.1.2 24
[R2-Serial4/0/0]int lo0  
[R2-LoopBack0]ip address 2.2.2.2 24
[R2-LoopBack0]q  
[R2]interface Serial 4/0/1 
[R2-Serial4/0/1]ip address 23.1.1.2 24
[R2-Serial4/0/1]q
[R2]aaa    
[R2-aaa]local-user a password cipher 123456
Info: Add a new user.
[R2-aaa]local-user a service-type ppp
[R2-aaa]q
[R2]int s4/0/1   
[R2-Serial4/0/1]ppp authentication-mode pap 
[R2-Serial4/0/1]q
[R2]int s3/0/0
[R2-Serial3/0/0]ip address 24.1.1.1 24  
[R2-Serial3/0/0]ppp authentication-mode chap 
[R2-Serial3/0/0]q
[R2]aaa
[R2-aaa]local-user b password cipher 654321
Info: Add a new user.  
[R2-aaa]local-user b service-type ppp

R1:

[R1]int g0/0/1  
[R1-GigabitEthernet0/0/1]ip address 192.168.1.1 24

[R1]interface Serial 4/0/0   
[R1-Serial4/0/0]ip address 12.1.1.1 24
[R1-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y

[R1]ip route-static 0.0.0.0 0 12.1.1.2

[R1]interface Tunnel 0/0/0
[R1-Tunnel0/0/0]ip address 192.168.4.1 24  
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp    
[R1-Tunnel0/0/0]source 12.1.1.1
Jan  5 2023 11:16:02-08:00 R1 %%01IFNET/4/LINK_STATE(l)[5]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[R1-Tunnel0/0/0]nhrp entry multicast dynamic  
[R1-Tunnel0/0/0]nhrp network-id 100

[R1]rip 1
[R1-rip-1]ver 2  
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 192.168.4.0

 R3:

[R3]int s4/0/0    
[R3-Serial4/0/0]ip address 23.1.1.1 24
[R3-Serial4/0/0]ppp pap local-user a password cipher 123456

[R3]ip route-static 0.0.0.0 0 23.1.1.2

[R3]int g0/0/1
[R3-GigabitEthernet0/0/1]ip address 192.168.2.1 24 
[R3]interface Tunnel 0/0/0
[R3-Tunnel0/0/0]ip address 192.168.4.3 24    
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp  
[R3-Tunnel0/0/0]source Serial 4/0/0
Jan  5 2023 11:23:53-08:00 R3 %%01IFNET/4/LINK_STATE(l)[10]:The line protocol IP
 on the interface Tunnel0/0/0 has entered the UP state.    
[R3-Tunnel0/0/0]nhrp entry 192.168.4.1 12.1.1.1 register  
[R3-Tunnel0/0/0]nhrp network-id 100

[R3]rip 1  
[R3-rip-1]ver 2
[R3-rip-1]network 192.168.2.0
[R3-rip-1]network 192.168.4.0
 

R4:

[R4]int s4/0/0
[R4-Serial4/0/0]ip address 24.1.1.2 24
[R4-Serial4/0/0]ppp chap user b
[R4-Serial4/0/0]ppp chap password cipher 654321

[R4]ip route-static 0.0.0.0 0 24.1.1.1

 [R4]int g0/0/1 
[R4-GigabitEthernet0/0/1]ip address 192.168.3.1 24

 [R4]interface Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 192.168.4.4 24
[R4-Tunnel0/0/0]tunnel-protocol gre p2mp   
[R4-Tunnel0/0/0]source Serial 4/0/0
Jan  5 2023 11:28:09-08:00 R4 %%01IFNET/4/LINK_STATE(l)[27]:The line protocol IP
 on the interface Tunnel0/0/0 has entered the UP state. 
[R4-Tunnel0/0/0]nhrp entry 192.168.4.1 12.1.1.1 register  
[R4-Tunnel0/0/0]nhrp network-id 100

[R4]rip 1    
[R4-rip-1]ver 2   
[R4-rip-1]network 192.168.4.0
[R4-rip-1]network 192.168.3.0

 

 

 [R1]int t0/0/0
[R1-Tunnel0/0/0]undo rip split-horizon

 [R1]acl 2000 
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1-acl-basic-2000]int s4/0/0 
[R1-Serial4/0/0]nat outbound 2000

[R3]acl 2000 
[R3-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R3-acl-basic-2000]int s4/0/0
[R3-Serial4/0/0]nat outbound 2000


[R4]acl 2000 
[R4-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R4-acl-basic-2000]int s4/0/0 
[R4-Serial4/0/0]nat outbound 2000

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值