数据结构练习二:01:整数顺序表的基本运算

01:整数顺序表的基本运算

总时间限制: 

10000ms

内存限制: 

10000kB

描述

设计整数顺序表的基本运算程序,并用相关数据进行测试

输入

顺序输入顺序表A的元素个数及各个元素

输出

第一行:创建顺序表A后,输出所有元素
第二行:删除第一个元素,输出删除后的所有元素
第三行:输出删除元素后顺序表的长度
第四行:在第二元素处插入一个新的元素100
第五行:输出第一个元素100所在位置

样例输入

6
1 2 3 4 0 9

样例输出

1 2 3 4 0 9
2 3 4 0 9
5
2 100 3 4 0 9
2

来源

《数据结构简明教程》上机实验2-基础实验题1

#include<iostream>
#include<list>
using namespace std;
int main()
{
	list<int>a;
	int n;
	cin >> n;
	for (int i = 1; i <= n; i++)
	{
		int temp;
		cin >> temp;
		a.push_back(temp);
	}
	list<int>::iterator it;
	for (it = a.begin(); it != a.end(); it++)
	{
		cout << *it<<" ";
	}
	cout << endl;
	a.pop_front();
	n = n - 1;
	for (it=a.begin(); it!=a.end(); it++)
	{
		cout << *it << " ";
	}
	cout << endl;
	cout << a.size() << endl;
	it = a.begin();
	it++;
	a.insert(it, 100);
	n++;
	for (it=a.begin(); it != a.end(); it++)
	{
		cout << *it << " ";
	}
	cout << endl;
	int temp = 0;
	for (it = a.begin(); it != a.end(); it++)
	{
		temp++;
		if (*it == 100)
		{
			cout << temp << endl;
			break;
		}
		
	}
	return 0;
}

  • 0
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值