PAT (Advanced Level) Practice 1006 Sign In and Sign Out—Python

摘要

考察时间格式的转换和列表的关键字排序

原题

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

<span style="color:#404040"><code>ID_number Sign_in_time Sign_out_time
</code></span>

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are 一致. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

题目意思

给定N个用户,下面给出N行分别是每个用户的ID,用户登录和登出的时间。现在找出登录时间最早和最晚登出的人。

思路

将用户存到二维列表中,将所有登录登出时间转化为datatime型,然后分别对登录时间排序找最小和对登出时间找最大找出登录时间最早和最晚登出的人然后存到列表中输出

Python代码

import datetime

N = int(input())
number_list = []  # 创建一个空列表number_list,用于存储输入的时间序列数据
ans = []  # 创建一个空列表ans,用于存储结果

for i in range(N):
    number_list.append((input().split()))  # 将输入的数据以空格为分隔符分割,并存储到number_list中

for number in number_list:  # 将字符串时间转换为datetime对象方便后面排序寻找最早最晚时间
    number[1] = datetime.datetime.strptime(number[1], '%H:%M:%S')
    number[2] = datetime.datetime.strptime(number[2], '%H:%M:%S')

number_list.sort(key=lambda x: x[1])  # 找到最早时间
ans.append(number_list[0][0])  # 把最早的时间添加到ans中
number_list.sort(key=lambda x: x[2], reverse=True)  # 找到最晚时间
ans.append(number_list[0][0])  # 把最晚的时间添加到ans中
print(" ".join(i for i in ans))

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值