PAT (Advanced Level) Practice 1005 Spell It Right—Python

摘要

很基础的题目,考察对于数据存储的知识

原题

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题目意思

输入一个数,将数的每一位加起来得到一个sum,将这个sum用英文逐位输出

思路

输入的是一个字符串,用迭代器把每一位取出来存进列表,再用sum对列表求和并逐位存进列表,最后制作一个字母表遍历输出即可

Python代码

words = ["zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"]
num_list = [i for i in input()]  # 输入数字
ans_list = [i for i in str(sum(int(n) for n in num_list))]  # 求和
print(" ".join(words[int(i)] for i in ans_list))
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值