基于二叉链表的二叉树叶子结点到根结点的路径的求解
描述
设二叉树中每个结点的元素均为一个字符,按先序遍历的顺序建立二叉链表,编写算法求出每个叶子结点到根结点的路径。
输入
多组数据。每组数据一行,为二叉树的先序序列(序列中元素为‘0’时,表示该结点为空)。当输入只有一个“0”时,输入结束。
输出
每组数据输出n行(n为叶子结点的个数),每行为一个叶子结点到根节点的路径(按照叶子结点从左到右的顺序)。
输入样例 1
abcd00e00f00ig00h00 abd00e00cf00g00 0
输出样例 1
dcba ecba fba gia hia dba eba fca gca
#include<iostream>
using namespace std;
#define Maxsize 100
char b[1000];
typedef struct BiNode {
char data;
BiNode* lchild, * rchild;
}BiNode,*BiTree;
void Create(BiTree& t,char a[],int &i) {//递归建立二叉链树
if (a[i] == '0') {
t = NULL;
}
else {
t = new BiNode;
t->data = a[i];
Create(t->lchild, a, ++i);
Create(t->rchild, a, ++i);
}
}
void Dfs(BiTree& t, int n) {
if (t) {
b[n] = t->data;
if (t->lchild == NULL && t->rchild == NULL) {
for (int i = n; i >= 0; i--) {
cout << b[i];
}
cout << endl;
}
else {
Dfs(t->lchild, n+1);
Dfs(t->rchild, n+1);
}
}
}
int main() {
char a[1000];
while (cin>>a&&a[0]!='0') {
int i = -1;
BiTree t;
Create(t, a, ++i);
Dfs(t, 0);
}
return 0;
}