1136 A Delayed Palindrome

Consider a positive integer N written in standard notation with k+1 digits a_i as a_k…a_1a_0 with 0 <= a_i < 10 for all i and a_k > 0. Then N is palindromic if and only if a_i = a_{k-i} for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.

Sample Input:

97152

Sample Output:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

cpp代码

#include<iostream>
#include<algorithm>
using namespace std;
bool check(string s){
    string back=s;
    reverse(back.begin(),back.end());
    if(s==back)return true;
    else return false;
}
int main(){
    string str;
    cin>>str;
    string rts=str;
    reverse(rts.begin(),rts.end());
    if(rts==str){
        printf("%s is a palindromic number.",str.c_str());
        return 0;
    }
    for(int i=0;i<10;i++){
        string res="";
        int t=0;
        for(int j=str.size()-1;j>=0;j--){
            t+=str[j]-'0'+rts[j]-'0';
            res+=to_string(t%10);
            t/=10;
        }
        if(t)res+=to_string(t);
        reverse(res.begin(),res.end());
        
        cout<<str<<" + "<<rts<<" = "<<res<<endl;
        if(check(res)){
            printf("%s is a palindromic number.\n",res.c_str());
           return 0;
        }
        str=res;
        rts=str;
        reverse(rts.begin(),rts.end());
    }
    puts("Not found in 10 iterations.");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值