1173 How Many Ways to Buy a Piece of Land

The land is for sale in CyberCity, and is divided into several pieces. Here it is assumed that each piece of land has exactly two neighboring pieces, except the first and the last that have only one. One can buy several contiguous(连续的) pieces at a time. Now given the list of prices of the land pieces, your job is to tell a customer in how many different ways that he/she can buy with a certain amount of money.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: N ( ≤ 1 0 4 \leq 10^4 104), the number of pieces of the land (hence the land pieces are numbered from 1 to N in order), and M ( ≤ 1 0 9 \leq 10^9 109), the amount of money that your customer has.
Then in the next line, N positive integers are given, where the i-th one is the price of the i-th piece of the land.
It is guaranteed that the total price of the land is no more than 1 0 9 10^9 109.

Output Specification:

For each test case, print the number of different ways that your customer can buy. Notice that the pieces must be contiguous.

HinSample Input:

5 85
38 42 15 24 9

Sample Output:

11

思路

因为是连续的,可以用前缀和来做

cpp代码

#include<iostream>
using namespace std;
const int N=1e4+10;
int ans[N];
int cnt;
int main(){
	int n,m;
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		cin>>ans[i];
		ans[i]+=ans[i-1];
	}
	for(int i=0;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			if(ans[j]-ans[i]<=m)cnt++;
		}
	}
	cout<<cnt<<endl;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值