标题
约瑟夫环
时间限制
2 S
内存限制
10000 Kb
问题描述
习题集P79。编号为1,2,...,n的n个人按顺时针方向围坐一圈,每人持有一个密码(正整数)。现在给定一个随机数m>0,从编号为1的人开始,按顺时针方向1开始顺序报数,报到m时停止。报m的人出圈,同时留下他的密码作为新的m值,从他在顺时针方向上的下一个人开始,重新从1开始报数,如此下去,直至所有的人全部出圈为止。
问题输入
输入数据第一行为两个正整数n和m,分别表示人的个数及初始随机数,每组数据的第二行为n个整数,表示每个人持有的密码。
问题输出
用一行输出n个整数表示依次出圈人的编号,整数之间用空格分隔
输入样例
7 20
3 1 7 2 4 8 4
输出样例
6 1 4 7 2 3 5
提示
使用不带头节点的循环链表
这题很简单,但是我的思路没有打开,导致一开始想了好久。
采用循环链表,然后用一个index存储下标
typedef struct node {
int data;
struct node *next;
int index;
} node, *lnode;
注意:内循环的条件,因为消除了要减去note
for (int i = 0; i < (b % (a - (note))) - 2; i++)
创建循环链表时也要注意结尾连到到开头的形态
if (d < a - 1) {
c->next = (lnode )malloc(sizeof(node));
c = c->next;
} else
c->next = f;
总体来说不难,但是注意的点很多
下面是完整代码
#include <stdio.h>
#include <stdlib.h>
#define maxsize 100
typedef struct node {
int data;
struct node *next;
int index;
} node, *lnode;
void start(lnode c, int a) {
int d = 0;
lnode f = c;
while (d < a) {
int e;
scanf("%d", &e);
c->data = e;
c->index = d + 1;
if (d < a - 1) {
c->next = (lnode )malloc(sizeof(node));
c = c->next;
} else
c->next = f;
d++;
}
}
void remake(lnode c, int a, int b) {
int newa[maxsize];
for (int note = 0; note < a; note++) {
for (int i = 0; i < (b % (a - (note))) - 2; i++) //使链表位于要消除的前一个
c = c->next;
newa[note] = c->next->index;//存储链表的位置
b = c->next->data;//消除已经走过的链表
c->next = c->next->next;
c = c->next;
}
for (int i = 0; i < a; i++) {
printf("%d ", newa[i]);
}
}
int main() {
int a, b; //7 20
scanf("%d%d", &a, &b);
node c;
start(&c, a); //将输入的值赋给循环链表;
remake(&c, a, b);
return 0;
}