(Java)1019 General Palindromic Number分数 20

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai​ as ∑i=0k​(ai​bi). Here, as usual, 0≤ai​<b for all i and ak​ is non-zero. Then N is palindromic if and only if ai​=ak−i​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

是不是看懵了,咋看也看不懂,其实它想表达的意思就是给你一个正整数N,一个进制b,把N转化为b进制下的数,看他是不是回文

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.

每个输入文件包含一个测试用例。每种情况由两个正数N和b组成,其中0<N≤109是十进制数,2≤b≤109是基数。这些数字用空格隔开。

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "ak​ ak−1​ ... a0​". Notice that there must be no extra space at the end of output.

对于每个测试用例,如果N是以b为底的回文数,则首先在一行中打印“是”,如果不是,则打印“否”。然后在下一行中,以“ak”的形式将N作为基数b中的数字打印出来​ak−1​。。。a0​“。请注意,在输出的末尾不能有多余的空间。

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

import java.util.Scanner;


public class Main {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        int b = in.nextInt();
        int[] num = new int[40];
        int index = 0;
        
        while (N != 0) {
            num[index++] = N % b;
            N /= b;
        }
        
        if (isPalindromic(num, index)) {
            System.out.println("Yes");
        } else {
            System.out.println("No");
        }
        for (int i = index-1; i >= 0; i--) {
            System.out.print(num[i]);
            if (i != 0) {
                System.out.print(" ");
            }
        }
    }

    public static boolean isPalindromic(int[] num, int index) {
        for (int i = 0; i < index / 2; i++) {
            if (num[i] != num[index - i - 1]) {
                return false;
            }
        }
        return true;
    }

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值