uva122

Background
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics.

This problem involves building and traversing binary trees.

The Problem
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes.

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1.

For example, a level order traversal of the tree

is: 5, 4, 8, 11, 13, 4, 7, 2, 1.

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specifiedif every node on all root-to-node paths in the tree is given a value exactly once.

The Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses.

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file.

The Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed.

Sample Input
(11,LL) (7,LLL) (8,R)
(5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
(3,L) (4,R) ()
Sample Output
5 4 8 11 13 4 7 2 1
not complete
 


指针实现二叉树版: 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn=10010;

struct node{
	
	int data;
	bool f;
	node* left;
	node* right;
	
	node():data(0),f(false),left(NULL),right(NULL){}
};

node* root=NULL;
char s[maxn];
bool failed=false;
vector<int> ans;

void addnode(int v,char s[]){

	int n=strlen(s);
	node* u=root;
	for(int i=0;i<n;i++){
		
		if(s[i]=='L'){
			
			if(u->left==NULL) u->left=new node;
			u=u->left;
		}else if(s[i]=='R'){
			
			if(u->right==NULL) u->right=new node;
			u=u->right;			
		}  
		
	}

	if(u->f) failed=true;	
	u->data=v;
	u->f=1;
}

bool read_input(){

	failed=false;
	root=new node;
	ans.clear(); 
	for(;;){
	   
	   if(scanf("%s",s)==EOF) return false;
	   if(strcmp(s,"()")==0) break;
	
	   	 int v;
	     sscanf(&s[1],"%d",&v);		
		 addnode(v,strchr(s,',')+1);
	}
	
	return true;
}


bool bfs(){

	queue<node*> q;
	q.push(root);
	
	while(!q.empty()){
		
		node* u=q.front(); q.pop();
		
		if(u->f==false) return false;
		ans.push_back(u->data);
		
		if(u->left!=NULL) q.push(u->left);
		if(u->right!=NULL) q.push(u->right);
	}
	
	return true;
}

int main(){
	
	while(read_input()){
		
		if(failed||!bfs())
		 printf("not complete\n");
		else{
			
			for(int i=0;i<ans.size();i++){
				
				if(i) putchar(' ');
				printf("%d",ans[i]);
			}
			puts("");
		}
	}

	return 0;
}

用数组实现二叉树版: 


int cnt=0;
const int root=1;

bool f[maxn];
int  a[maxn];
int left[maxn],right[maxn];

void newtree(){
	
	cnt=root; left[root]=right[root]=0; f[root]=false;
}

int newnode(){
	
	int u=++cnt; left[u]=right[u]=0; f[u]=false;
	return u; 
}


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<queue>
#include<vector>
#define mem(a,x) memset(a,0,sizeof(a))
using namespace std;
const int maxn=10010;
const int N=10;

char s[maxn];
bool failed=false;
vector<int> ans;

int cnt=0;
const int root=1;
bool f[maxn];
int a[maxn];
int lch[maxn],rch[maxn];

void newtree(){
	
	cnt=root; 
	f[root]=false; a[root]=0;
	lch[root]=rch[root]=0; 
}

int newnode(){
	int u=++cnt;  lch[u]=rch[u]=0; f[u]=false; a[u]=0;
	return u;
}

void addnode(int v,char s[]){
	
	int n=strlen(s);
	int u=root;
	for(int i=0;i<n;i++){
		
		if(s[i]=='L'){
		  
		  if(lch[u]==0) lch[u]=newnode();
		    u=lch[u];
		}else if(s[i]=='R'){
			
		  if(rch[u]==0) rch[u]=newnode();
		  u=rch[u];
		}
	}	
	
		if(f[u]) failed=true;
		a[u]=v;
		f[u]=true;		
	
}

bool read_input(){
	
	failed=false;
	ans.clear();
	mem(a,0),mem(f,false);
	mem(lch,0),mem(rch,0);
	
	newtree();
	
	for(;;){
		
		if(scanf("%s",s)==EOF) return false;
		if(strcmp(s,"()")==0) break;
		
		int v;  char str[maxn];
		sscanf(s+1,"%d,%s",&v,str);
		addnode(v,str);
	}
	
	return true;
}

bool bfs(){
	
	queue<int> q;
	q.push(root);
	
	while(!q.empty()){
		
		int u=q.front(); q.pop();
		
		if(f[u]==0) return false;
		ans.push_back(a[u]);
		
		if(lch[u]) q.push(lch[u]);
		if(rch[u]) q.push(rch[u]);
	}
	
	return true;
}

int main(){

	while(read_input()){
		
		if(failed||!bfs()){
			
			printf("not complete\n");
		}else{
			
			for(int i=0;i<ans.size();i++){
				
			 if(i) putchar(' ');
			  printf("%d",ans[i]);
			}
			
			puts("");
		}
			
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值