1030 完美数列 (25分)

 

给定一个正整数数列,和正整数 p,设这个数列中的最大值是 M,最小值是 m,如果 M≤mp,则称这个数列是完美数列。

现在给定参数 p 和一些正整数,请你从中选择尽可能多的数构成一个完美数列。

输入格式:

输入第一行给出两个正整数 N 和 p,其中 N(≤10​5​​)是输入的正整数的个数,p(≤10​9​​)是给定的参数。第二行给出 N 个正整数,每个数不超过 10​9​​。

输出格式:

在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。

输入样例:

10 8
2 3 20 4 5 1 6 7 8 9

输出样例:

8
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<string>
#include<vector> 
using namespace std;
const int maxn=10010;
const int N=10;
typedef long long LL;
int main(){

	LL n,p;
	cin>>n>>p;
	
	vector<LL> a(n);
	for(int i=0;i<n;i++)
		cin>>a[i];
		
	sort(a.begin(),a.end());
	
	int len=1;
	for(int i=0;i<n;i++){
		
		for(int j=i+len;j<n;j++){
			
			if( a[j] <= a[i]*p){
				
				LL t = j-i+1;
				if(t>len) len=t;
				
			} else break;
		}
	}
	
	cout<<len<<endl;
	
	return 0;
}

下面这样就错了一个测试点,思路是一样的但是会超时,每次多走了几步

	int len=1;
	for(int i=0;i<n;i++){
		
		for(int j=n-1;j-i+1>len;j--){
			
			if( a[j] <= a[i]*p){
				
				LL t = j-i+1;
				if(t>len) len=t;
				
				break;
			} 
		}
	}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值