poj 1308 Is It A Tree?

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.

Case 3 is not a tree.

题意:就是给你关系,当0 0 这组数据结束,-1-1 输入结束,怕毛短给你的关系能不能组成一颗树

所以要根据所给的关系判断1.所有的点,入度只能为1 2.判断是否形成了环 3.根节点只有一个

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;
int father[10005];
int in[10005];
int book[10005];
int f,maxn;
int Find(int x){

while(father[x]!=x)
    x=father[x];
return x;
}
void made(int x,int y){
 int fx,fy;
 fx=Find(x);
 fy=Find(y);
 if(fx!=fy)
    father[fy]=fx;
 else
 {
     f=1;//形成了环
  
 }

}
int main(){
    int i,j;
    int a,b;
    int cas=0;
    memset(in,0,sizeof(in));
    memset(book,0,sizeof(book));
    for(i=1;i<10005;i++)
        father[i]=i;
    f=maxn=0;
    while(scanf("%d%d",&a,&b) && a!=-1 && b!=-1 ){
        if(a==0 && b==0){
                cas++;
              int f2;
              f2=0;
             for(i=1;i<=maxn;i++){
                if(father[i]==i && book[i]) f2++;//根节点的个数
                if(in[i]>1) f=1;//入度不能大于1
             }
             if(f2>1)  printf("Case %d is not a tree.\n",cas);

             else{
                if(f)
                   printf("Case %d is not a tree.\n",cas);
                   else
                printf("Case %d is a tree.\n",cas);
             }
        //    printf("f=%d f2=%d\n",f,f2);

            memset(in,0,sizeof(in));
            memset(book,0,sizeof(book));
             for(i=1;i<10005;i++)
               father[i]=i;
             f=maxn=0;
             continue;
        }
        in[b]++;//入度数
        book[a]=1;//判断这个数是否出现
        book[b]=1;
        if(maxn<a) maxn=a;
        if(maxn<b) maxn=b;
        made(a,b);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值