POJ - 3268 Silver Cow Party(spfa)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; roadi requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units. 

题意:就是1~n点的牛要去x点参加聚会,单向路,来的路和回去的路不一样,让你求是每个牛来回最短路中的最大的

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define INF 99999999
int map1[1005][1005],dis1[1005];
int map2[1005][1005],dis2[1005];
int n;
int init() {
    int i,j;
    for(i=1; i<=n; i++) {
        for(j=1; j<=n; j++) {
            map1[i][j]=INF;
            map2[i][j]=INF;
        }
        dis1[i]=dis2[i]=INF;
    }
}
void spfa(int x,int Map[1005][1005],int dis[1005]) {
    int book[1005],i,j;
    memset(book,0,sizeof(book));
    queue<int>q;
    while(!q.empty()) q.pop();
    i=x;
    book[i]=1;
    dis[i]=0;
    q.push(i);
    while(!q.empty()) {
        i=q.front();
        q.pop();
        for(j=1; j<=n; j++) {
            if(Map[i][j]!=INF && book[j]==0) {
                if(dis[j]>Map[i][j]+dis[i]) {
                    dis[j]=Map[i][j]+dis[i];//更新j点的最短距离
                    q.push(j);
                }
            }
        }
    }

}
int main() {
    int m,x;
    int i,j;
    int a,b,c;
    while(scanf("%d%d%d",&n,&m,&x)!=EOF) {
        init();//初始化
        while(m--) {
            scanf("%d%d%d",&a,&b,&c);
            map1[a][b]=c;
            map2[b][a]=c;//存成两个图,这样方便计算所有点到x点
        }
        spfa(x,map1,dis1);
        spfa(x,map2,dis2);//都是从x点到其他点
        int ans=0;
        for(i=1;i<=n;i++){
                ans=max(ans,dis1[i]+dis2[i]);
        }
        printf("%d\n",ans);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值