Wormholes (最短路-负权边问题)

    While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

    As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

    To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
    Line 1: A single integer, F. F farm descriptions follow.
    Line 1 of each farm: Three space-separated integers respectively: N, M, and W
    Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
    Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
    Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input

    2
    3 3 1
    1 2 2
    1 3 4
    2 3 1
    3 1 3
    3 2 1
    1 2 3
    2 3 4
    3 1 8

Sample Output

    NO
    YES

Hint
    For farm 1, FJ cannot travel back in time.
    For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意:负权边问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b花费的时间是-c(时间倒流,并且虫洞是单向的),问是否存在从一个地点到另一个地点在经过虫洞回到刚开始的地点且时间更向前。

分析:解决本题比较简单的方法就是弗洛伊德算法了,需要注意的是正权边是双向的,负权边是单向的。

#include<stdio.h>
int main()
{
	int i,j,k,m,n,w,t,t1,t2,t3,flag;
	int e[510][510];
	int inf = 99999999;
	scanf("%d",&t);
	while(t --)
	{
		flag = 0;
		scanf("%d%d%d",&n,&m,&w);
		for(i = 1; i <= n; i ++)
			for(j = 1; j <= n; j ++)
				e[i][j] = inf;
		for(i = 1; i <= m; i ++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			if(e[t1][t2] > t3)
				e[t1][t2] = e[t2][t1] = t3;
		}
		for(i = 1; i <= w; i ++)
		{
			scanf("%d%d%d",&t1,&t2,&t3);
			e[t1][t2] = -t3;
		}
		for(k = 1; k < n; k ++)
		{
			for(i = 1; i <= n; i ++)
			{
				for(j = 1; j <= n; j ++)
					if(e[i][j] > e[i][k] + e[k][j])
						e[i][j] = e[i][k] + e[k][j];
				if(e[i][i] < 0)
					flag = 1;
			}
			if(flag == 1)
				break;
		}
		if(flag == 1)
			printf("YES\n");
		else
			printf("NO\n");	
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值