POJ--2299--线段树+离散化查找逆序对

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,


Ultra-QuickSort produces the output

0 1 4 5 9 .


Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input
5
9 1 0 5 4 

3
1 2 3
0
Sample Output
6
0

思路:Sample可知求冒泡排序交换的次数,离散化数据

数状数组模板:https://blog.csdn.net/queque_heiya/article/details/103947311

具体代码如下:

#include<iostream>
using namespace std;
#include<cstdio>
#include<cstring>
#include<algorithm>
typedef long long ll;
const int MAX_N=500000+1;
int bit[MAX_N+1],n; 
int a[MAX_N];
struct name{
	int u,v;//v在这里表示id,下标 
}s[MAX_N];
bool comp(const name &a,const name &b){
	return a.u<b.u;
}
int sum(int i){
	int s=0;
	while(i>0){
		s+=bit[i];
		i-=i&-i;
	}
	return s;
}
void add(int i,int x){
	while(i<=n){ 
		bit[i]+=x;
		i+=i&-i;
	} 
}
int main(){
	while(1){ 
		cin>>n;
		if(n==0)	break; 
		memset(bit,0,sizeof(bit)); 
		for(int i=1;i<=n;i++){ 
			cin>>s[i].u;
			s[i].v=i; 
		} 
		sort(s+1,s+1+n,comp);//对结构体进行排序 
		for(int i=1;i<=n;i++) 
			a[s[i].v]=i;//离散化的过程,依次赋值1,2,3,4,...n-1,n.即对应的下标//0<=a[i]<=999,999,999数据太大不可接受 
		ll ans=0;
		for(int j=1;j<=n;j++){
			add(a[j],1);
			ans+=j-sum(a[j]);
		} 
		printf("%lld\n",ans);
	} 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值