归并排序

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
题目大意:给你一串数,问将这一串数从小到大排序,需要变换几次。
这道题运用到了归并排序。
什么是归并排序?
归并排序指的是将两个顺序序列合并成一个顺序序列的方法。
举一个例子
9 1 0 5 4 3 2 8
第一次合并{1,9},{0,5},{3,4},{2,8}
第二次合并{0,1,5,9},{2,3,4,8}
第三次合并{0,1,2,3,4,5,8,9}
最后将比较的次数加起来就是最终的结果

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[2000000],b[2000000];
long long ans;
void uninite(int x,int mid,int y)
{
    int i=x,j=mid+1,k=x;
    while(i<=mid&&j<=y)
    {
        if(a[i]<=a[j])
            b[k++]=a[i++];
        else
        {
            b[k++]=a[j++];
            ans+=(mid-i+1);
        }
    }
    while(i<=mid)
        b[k++]=a[i++];
    while(j<=y)
        b[k++]=a[j++];
        for(i=x;i<=y;i++)
            a[i]=b[i];
}
void merge(int x,int y)
{
    if(x<y)
    {
        int mid=(x+y)/2;
        merge(x,mid);
        merge(mid+1,y);
        uninite(x,mid,y);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        ans=0;
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        merge(0,n-1);
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值