HDU--3792--Twin Prime Conjecture--筛选素数+前缀和

If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.

Input

Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.

Output

For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.

Sample Input
1
5
20
-2
Sample Output
0
1
4

思路一:不采用前缀和,时间超时!暴力查找不可;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
using namespace std;
const int maxa=1e5+10;
bool a[maxa];
int m;
bool prime(int n){
	for(int i=2;i<=sqrt(n);i++)
		if(n%i==0)	return false;
	return true;
} 
int main(){
	memset(a,false,sizeof a);
	for(int i=2;i<=maxa;i++)
		if(prime(i))	a[i]=!a[i];
	while(scanf("%d",&m)!=EOF&&m>=0){
		int ans=0;
		for(int i=5;i<=m;i++)
			if(a[i]&&a[i-2])
				ans++;
		cout<<ans<<endl;
	}
}

思路二:1.素数筛法标记出所有素数;

2.一个素数i,判断i-2是否是素数,是的话就把a[i]赋值为1;

3.最后求出所有前缀和;

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<stack>
using namespace std;
const int maxa=1e5+10;
bool a[maxa];
int ans[maxa],ANS[maxa];
int m;
bool prime(int n){
	for(int i=2;i<=sqrt(n);i++)
		if(n%i==0)	return false;
	return true;
} 
int main(){
	memset(a,false,sizeof a);
	memset(ans,0,sizeof ans);
	for(int i=2;i<=maxa;i++)
		if(prime(i)){
			a[i]=!a[i];
			if(a[i-2])	ans[i]=1; 
	} 
	ANS[0]=ans[0];
	for(int i=1;i<=maxa;i++)
		ANS[i]=ANS[i-1]+ans[i];//统计前缀和 
	while(scanf("%d",&m)!=EOF&&m>=0){
		printf("%d\n",ANS[m]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值