HDU 3792 Twin Prime Conjecture(素数筛法 + 树状数组)

Twin Prime Conjecture

Problem Description
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that "There are infinite consecutive primes differing by 2".
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
 

Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
 

Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
 

Sample Input
  
  
1 5 20 -2
 

Sample Output
0
1
4

【思路分析】
   求n的范围内孪生素数的个数。所谓的孪生素数就是相差为2的一对素数。
   首先可以根据素数筛法用visited数组标记数字i是否为素数,并且可以判断数字i和数字i - 2是否均为素数,如果是,就将数组num[i]标记为1,最后再用一个数组记录num的每一段区间的和即可。求区间和的时候用树状数组优化了一下。

代码如下:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn = 100005;
int n;
int num[maxn],c[maxn];
int ans[maxn];
int visited[maxn];//标记素数
int lowbit(int x)
{
    return x & (-x);
}
int sum(int i)
{
    int ans = 0;
    while(i > 0)
    {
        ans += c[i];
        i -= lowbit(i);
    }
    return ans;
}
void add(int i,int w)
{
    while(i <= maxn)
    {
        c[i] += w;
        i += lowbit(i);
    }
}
void init()
{
    memset(visited,0,sizeof(visited));
    memset(num,0,sizeof(num));
    memset(c,0,sizeof(c));
    visited[0] = visited[1] = 1;//即0和1
    for(int i = 2;i < maxn;i++)//i即表示数字i
    {
        if(!visited[i])
        {
            if(!visited[i - 2])
            {
                num[i] = 1;//标记i和i-2是否为孪生素数
                add(i,1);
            }
        }
        for(int j = i << 1;j < maxn;j += i)//筛素数
        {
            visited[j] = 1;
        }
    }
    /*
    ans[0] = 0;
    for(int i = 1;i < maxn;i++)//区间求和
    {
        ans[i] = ans[i - 1] + num[i];
    }
    */

}

int main()
{
    init();
    while(scanf("%d",&n) && n >= 0)
    {
        printf("%d\n",sum(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值