POJ--2195--Matrix--平面修改+单点查询

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output
1
0
0
1

思路:二维树状数组,平面修改+单点查询;直接上模板:https://blog.csdn.net/queque_heiya/article/details/105899571

注意:每两个连续测试用例之间有一个空白行,输出的ans只有0与1,因此可以输出1&ans即可,或者ans%2?1:0;

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<queue>
#include<cstdio>
#define LL long long 
using namespace std;
const int maxa=1e3+10;
LL n,q;
LL C[maxa][maxa];
LL lowbit(LL i){
	return i&-i;
}
void add(LL a,LL b,LL k){
	for(LL i=a;i<=n;i+=lowbit(i))
		for(LL j=b;j<=n;j+=lowbit(j))
			C[i][j]+=k;
}
LL sum(LL x,LL y){
	LL ans=0;
	for(LL i=x;i>0;i-=lowbit(i))
		for(LL j=y;j>0;j-=lowbit(j))
			ans+=C[i][j];
	return ans;
} 
int main(){
	LL t;
	scanf("%lld",&t);
	while(t--){
		scanf("%lld%lld",&n,&q);
		char op[3]; 
		LL a,b,c,d,x,y; 
		memset(C,0,sizeof C);
		for(int i=0;i<q;i++){
			scanf("%s",&op);
			if(op[0]=='C'){
				scanf("%lld%lld%lld%lld",&a,&b,&c,&d);
				add(a,b,1);
				add(c+1,d+1,1);
				add(c+1,b,-1);
				add(a,d+1,-1);
				//一维差分数组应该为:add(x,k),add(y+1,-k); 
			}
			else if(op[0]=='Q'){
				scanf("%lld%lld",&x,&y);
				printf("%lld\n",1&sum(x,y));//对于区间更新的查询,偶数==0,奇数==1 
			}
		}//注意:每两个连续测试用例之间有一个空白行
		if(t)	printf("\n"); 
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值