hdu_1100_Trees_Made_to_Order

Trees Made to Order

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 465    Accepted Submission(s): 271


Problem Description
We can number binary trees using the following scheme: 
The empty tree is numbered 0.
The single-node tree is numbered 1.
All binary trees having m nodes have numbers less than all those having m+1 nodes.
Any binary tree having m nodes with left and right subtrees L and R is numbered n such that all trees having m nodes numbered > n have either
Left subtrees numbered higher than L, or
A left subtree = L and a right subtree numbered higher than R.

The first 10 binary trees and tree number 20 in this sequence are shown below:



Your job for this problem is to output a binary tree when given its order number.
 

Input
Input consists of multiple problem instances. Each instance consists of a single integer n, where 1 <= n <= 500,000,000. A value of n = 0 terminates input. (Note that this means you will never have to output the empty tree.)
 

Output
For each problem instance, you should output one line containing the tree corresponding to the order number for that instance. To print out the tree, use the following scheme:

A tree with no children should be output as X.
A tree with left and right subtrees L and R should be output as (L')X(R'), where L' and R' are the representations of L and R.
If L is empty, just output X(R').
If R is empty, just output (L')X.
 

Sample Input
  
  
1 20 31117532 0
 

Sample Output
  
  
X ((X)X(X))X (X(X(((X(X))X(X))X(X))))X(((X((X)X((X)X)))X)X)
 

Source
 

Recommend
JGShining

个人理解:

要解决问题,主要是要得出左子树和右子树的序数。所以要首先得出整棵树在有相同节点数的树中排第几。另外就是要注意序数增长时,左右两个子树的变化规律。

#include <cstdio>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
#define PB push_back

typedef long long ll;

const int maxn=500000000;
vector<ll> sum,tree;

void init() {
    sum.PB(0);
    tree.PB(1);
    while(*sum.rbegin()<maxn) {
        tree.PB(0);
        for(int i=0;i<tree.size()-1;i++)
            *tree.rbegin()+=tree[i]*tree[tree.size()-i-2];
        sum.PB(*sum.rbegin()+*tree.rbegin());
    }
}

void dfs(int p) {
    if(!p)
        return ;
    int m=lower_bound(sum.begin(),sum.end(),p)-sum.begin();
    p-=sum[m-1];//该棵树在相同节点数的树中的序数
    int k=0,lp=1,rp;
    while(p>tree[m-1-k]*tree[k]&&m-1-k-1>=0) {
        p-=tree[m-1-k]*tree[k];
        k++;
    }//求左子树节点数
    if(k) {
        while(p>tree[m-1-k]) {
            p-=tree[m-1-k];
            lp++;
        }
        lp+=sum[k-1];//左子树序数
        printf("(");
        dfs(lp);
        printf(")");
    }
    printf("X");
    if(m-1-k) {
        rp=p+sum[m-1-k-1];//右子树序数
        printf("(");
        dfs(rp);
        printf(")");
    }
}

int main() {
    init();
    int n;
    while(cin >> n,n) {
        dfs(n);
        cout << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值