POJ - 1979 Red and Black

这个题是个深搜,并不复杂,注意递归 进入和跳出的条件,注意每次只能踩四个直冲着的方砖,首先把起始位置找出来,然后,进入递归,每次进入递归后把当前位置置为‘#’,防止多次进入同一个状态。对了,输入时,用gets()读入之前  一定getchar()一下,把回车吃掉,否则有一行将读不进来。

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cmath>

using namespace std;


char s[25][25];
int W ,H;
int cnt = 1;

void dfs(int x, int y)
{
    s[x][y] = '#';
    for(int dx = -1; dx <= 1 ;dx++)
    {
        for(int dy = -1 ; dy <= 1 ; dy++)
        {
            int nx = dx + x;
            int ny = dy + y;
            if( 0 <= nx && nx < H && 0 <= ny && ny < W && (abs(dx) != abs(dy)) && s[nx][ny] == '.')
            {
                cnt++;
                dfs(nx,ny);
//                printf("%d ,%d\n", nx,ny);
            }
        }
    }
    return;
}
void search(int *a, int *b)
{
    for(int i = 0 ; i < H ; i++)
    {
        for(int j = 0; j < W ; j++)
        {
            if(s[i][j] == '@')
            {
                *a = i;
                *b = j;
//                printf("@坐标为:%d% ,%d\n", i , j);
            }
        }
    }
    return;
}

int main()
{
//    freopen("1.txt","r", stdin);
    while(1)
    {
        cnt = 1;
        int x, y;
        int * a = &x;
        int * b = &y;

        cin>>W>>H;
        if(W==0&&H==0)
            break;
        getchar();
        for(int i = 0; i < H ; i++)
            gets(s[i]);
//            for(int i = 0; i < H ; i++)
//            puts(s[i]);
        search(a,b);
        dfs(x, y);

        cout<<cnt<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值