C - Find The Multiple(BFS)

14 篇文章 0 订阅

解题过程:直接暴搜;

解题思路:1,首先这个由01组成的数的开头一定是1。

2,每次在后面添上0或1 对所给的数取余,若为0则为这个数的解,不为0就继续在后面加0或加1。如此反复直到有解。

Tips:因为没做时间空间的优化,用C++编译器可能会TLE,用G++才能AC。

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
#include<cstdio>
#include<iostream>
#include<cmath>
#include<queue>

using namespace std;

void bfs(int x)
{
    queue<long long> que;
    que.push(1);
    while(que.size())
    {
        long long p = que.front();
        que.pop();
        if( p % x == 0)
        {
            printf("%lld\n", p);
            return;
        }
        que.push(p * 10);
        que.push(p * 10 + 1);
    }
}
int main()
{
    int x;
    while(scanf("%d", &x) && x)
    {
        bfs(x);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值