【POJ1442】 - - Black Box(优先队列)

该博客介绍了如何利用优先队列(最小堆和最大堆)解决POJ1442问题,即在一系列输入元素中找到第k小的数。博主提供了详细的解题思路,通过维护两个堆,在每次输出第k小的数时,将已输出的数放入最大堆,然后与最小堆进行比较调整,确保最小堆的最小值始终为第k小的数。博客还包含了一个示例交易序列和相应的输出结果。
摘要由CSDN通过智能技术生成

题意:按要求输出所给序列中第k小的数

解题思路:维护两个优先队列,一个最小堆,一个最大堆,最终想要的效果是每次输入就是弹出最小堆中的最小值就是所要的值,也就是说比最小值还要小的值,被想办法放到了别处(不能直接去掉,因为后面可能还会用到)。逆向思路是,每次输出完的那个数,把它放进最大堆中,在求第k个最小值时,前k个数都压进最小优先队列,如果最大优先队列不为空,就把最大值拿出来和最小优先队列的最小值比较,如果最小值小于最大值则交换。循环,这样最小堆的最小值就是第k小的数。

Description

Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:

ADD(x): put element x into Black Box; 

GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. 

Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non-descending.


Example 

Let us examine a possible sequence of 11 transactions:

N Transaction i Black Box contents after transaction Answer 
      (elements are arranged by non-descending)   
1 ADD(3)      0 3   
2 GET         1 3                                    3 
3 ADD(1)      1 1, 3   
4 GET         2 1, 3                                 3 
5 ADD(-4)     2 -4, 1, 3   
6 ADD(2)      2 -4, 1, 2, 3   
7 ADD(8)      2 -4, 1, 2, 3, 8   
8 ADD(-1000)  2 -1000, -4, 1, 2, 3, 8   
9 GET         3 -1000, -4, 1, 2, 3, 8                1 
10 GET        4 -1000, -4, 1, 2, 3, 8                2 
11 ADD(2)     4 -1000, -4, 1, 2, 2, 3, 8   

It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.

Let us describe the sequence of transactions by two integer arrays:


1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).

2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).

The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.


Input 

Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.


Output 

Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Sample Input

1

7 4
3 1 -4 2 8 -1000 2
1 2 6 6


Sample Output

3
3
1
2

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define MAX_N 30005
const int INF = 0x3f3f3f3f;
int num[MAX_N];

int main()
{
    int t;
    cin >> t;
    for(int o = 0 ; o < t ; )
    {
        priority_queue<int , vector<int>, greater<int> > pq1;
        priority_queue<int , vector<int>, less<int> > pq2;
        int n, m;
        int k = 0;
        scanf("%d%d", &n, &m);
        for(int i = 0 ; i < n ; i++) scanf("%d", &num[i]);
        for(int i = 0 ; i < m ; i++)
        {
            int u;
            scanf("%d", &u);
            while(k < u)
            {
                pq1.push(num[k]);
                if(!pq2.empty() && pq1.top() < pq2.top())
                {
                    int tmp = pq1.top();
                    pq1.pop();
                    pq1.push(pq2.top());
                    pq2.pop();
                    pq2.push(tmp);
                }
                k++;
            }
            cout<<pq1.top()<<endl;
            pq2.push(pq1.top());
            pq1.pop();
        }
        o++;
        if(o < t)
            cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值